summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSaultDon2015-07-02 10:19:09 -0700
committerSaultDon2015-07-02 10:19:09 -0700
commit06a2e4318bf4e19dee72b838a05658f6b0ec6925 (patch)
treebb8598228972fb2779e07b1b91944465cefa4d08
downloadaur-06a2e4318bf4e19dee72b838a05658f6b0ec6925.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD32
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..01b0129a77f6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = pgrouting
+ pkgdesc = Adds routing functionality to PostGIS/PostgreSQL
+ pkgver = 2.0.0
+ pkgrel = 8
+ url = http://pgrouting.org/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = cmake>=2.8.8
+ makedepends = boost
+ depends = postgis>=1.5
+ depends = gcc-libs
+ depends = cgal
+ source = pgrouting-2.0.0::git://github.com/pgRouting/pgrouting.git
+ md5sums = SKIP
+
+pkgname = pgrouting
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d609d2c96b54
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: SaultDon <sault.don gmail>
+# Contributor: Andre Klitzing <andre () incubo () de>
+
+pkgname=pgrouting
+pkgver=2.0.0
+pkgrel=8
+pkgdesc="Adds routing functionality to PostGIS/PostgreSQL"
+arch=('i686' 'x86_64')
+url="http://pgrouting.org/"
+license=('GPL2')
+depends=('postgis>=1.5' 'gcc-libs' 'cgal')
+makedepends=('cmake>=2.8.8' 'boost')
+source=("$pkgname-$pkgver"::git://github.com/pgRouting/pgrouting.git)
+md5sums=('SKIP')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ rm -rf build
+ mkdir build
+ cd build
+
+ cmake ../ \
+ -DWITH_DD=ON \
+ -DWITH_TSP=ON
+
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver/build"
+ make DESTDIR="$pkgdir/" install
+}