summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfahrenheit2018-04-08 18:26:51 +0100
committerfahrenheit2018-04-08 18:26:51 +0100
commit94e7c4e5d6cd6aa9d907db7451a9a7ee6f3b51b6 (patch)
treeb9c8b6bf624abe0c73949b4751e5d8b2481f64af
downloadaur-94e7c4e5d6cd6aa9d907db7451a9a7ee6f3b51b6.tar.gz
Added version 1.1.5 of PGSphere
Signed-off-by: fahrenheit <alka.setzer@gmail.com>
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD29
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cb5cb4845ca8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = pgsphere
+ pkgdesc = Provides spherical data types, functions, and operators for PostgreSQL
+ pkgver = 1.1.5
+ pkgrel = 1
+ url = http://pgfoundry.org/projects/pgsphere/
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = postgresql
+ options = !makeflags
+ source = pgsphere::git://github.com/akorotkov/pgsphere.git
+ sha256sums = SKIP
+
+pkgname = pgsphere
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..154d13a2ba4a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# $Id$
+# Maintainer: Miguel Gomes <alka.setzer@gmail.com>
+
+pkgname=pgsphere
+pkgver=1.1.5
+pkgrel=1
+pkgdesc="Provides spherical data types, functions, and operators for PostgreSQL"
+arch=('x86_64')
+url="http://pgfoundry.org/projects/pgsphere/"
+license=('GPL')
+makedepends=('git')
+depends=('postgresql' )
+options=('!makeflags')
+source=(pgsphere::git://github.com/akorotkov/pgsphere.git)
+sha256sums=('SKIP')
+
+prepare() {
+ cd pgsphere
+}
+
+build() {
+ cd pgsphere
+ make USE_PGXS=1 PG_CONFIG=/usr/bin/pg_config
+}
+
+package() {
+ cd pgsphere
+ make DESTDIR="${pkgdir}" USE_PGXS=1 PG_CONFIG=/usr/bin/pg_config install
+} \ No newline at end of file