summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authored2023-12-07 11:10:24 -0600
committered2023-12-07 11:10:24 -0600
commitc255929d3d32251ee45e18cfb9c9820222d1ccdc (patch)
tree91c5d7c42205adc47f004e1ea107a77c234986f2
downloadaur-pgxman.tar.gz
create pgxman AUR package
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore163
-rw-r--r--PKGBUILD39
3 files changed, 214 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4ce7e41373e5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = pgxman
+ pkgdesc = PostgreSQL Extension Manager
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://pgxman.com/
+ arch = x86_64
+ license = FSL-1.0-Apache-2.0
+ makedepends = go
+ source = https://github.com/pgxman/pgxman/archive/refs/tags/v1.0.1.tar.gz
+ sha256sums = 71f0986df8922df67fe20122776d6d46e7877233e3c52df3761f86d364c77a66
+
+pkgname = pgxman
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..958dc615c94f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,163 @@
+# Byte-compiled / optimized / DLL files
+__pycache__/
+*.py[cod]
+*$py.class
+
+# C extensions
+*.so
+
+# Distribution / packaging
+.Python
+build/
+develop-eggs/
+dist/
+downloads/
+eggs/
+.eggs/
+lib/
+lib64/
+parts/
+sdist/
+var/
+wheels/
+share/python-wheels/
+*.egg-info/
+.installed.cfg
+*.egg
+MANIFEST
+
+# PyInstaller
+# Usually these files are written by a python script from a template
+# before PyInstaller builds the exe, so as to inject date/other infos into it.
+*.manifest
+*.spec
+
+# Installer logs
+pip-log.txt
+pip-delete-this-directory.txt
+
+# Unit test / coverage reports
+htmlcov/
+.tox/
+.nox/
+.coverage
+.coverage.*
+.cache
+nosetests.xml
+coverage.xml
+*.cover
+*.py,cover
+.hypothesis/
+.pytest_cache/
+cover/
+
+# Translations
+*.mo
+*.pot
+
+# Django stuff:
+*.log
+local_settings.py
+db.sqlite3
+db.sqlite3-journal
+*.db
+# Flask stuff:
+instance/
+.webassets-cache
+
+# Scrapy stuff:
+.scrapy
+
+# Sphinx documentation
+docs/_build/
+
+# PyBuilder
+.pybuilder/
+target/
+
+# Jupyter Notebook
+.ipynb_checkpoints
+
+# IPython
+profile_default/
+ipython_config.py
+
+# pyenv
+# For a library or package, you might want to ignore these files since the code is
+# intended to run in multiple environments; otherwise, check them in:
+# .python-version
+
+# pipenv
+# According to pypa/pipenv#598, it is recommended to include Pipfile.lock in version control.
+# However, in case of collaboration, if having platform-specific dependencies or dependencies
+# having no cross-platform support, pipenv may install dependencies that don't work, or not
+# install all needed dependencies.
+#Pipfile.lock
+
+# poetry
+# Similar to Pipfile.lock, it is generally recommended to include poetry.lock in version control.
+# This is especially recommended for binary packages to ensure reproducibility, and is more
+# commonly ignored for libraries.
+# https://python-poetry.org/docs/basic-usage/#commit-your-poetrylock-file-to-version-control
+poetry.lock
+
+.poetry.lock
+
+# pdm
+# Similar to Pipfile.lock, it is generally recommended to include pdm.lock in version control.
+#pdm.lock
+# pdm stores project-wide configurations in .pdm.toml, but it is recommended to not include it
+# in version control.
+# https://pdm.fming.dev/#use-with-ide
+.pdm.toml
+
+# PEP 582; used by e.g. github.com/David-OConnor/pyflow and github.com/pdm-project/pdm
+__pypackages__/
+
+# Celery stuff
+celerybeat-schedule
+celerybeat.pid
+
+# SageMath parsed files
+*.sage.py
+
+# Environments
+.env
+.venv
+env/
+venv/
+ENV/
+env.bak/
+venv.bak/
+
+# Spyder project settings
+.spyderproject
+.spyproject
+
+# Rope project settings
+.ropeproject
+
+# mkdocs documentation
+/site
+
+# mypy
+.mypy_cache/
+.dmypy.json
+dmypy.json
+
+# Pyre type checker
+.pyre/
+
+# pytype static type analyzer
+.pytype/
+
+# Cython debug symbols
+cythikaaryhon_debug/
+
+# PyCharm
+# JetBrains specific template is maintained in a separate JetBrains.gitignore that can
+# be found at https://github.com/github/gitignore/blob/main/Global/JetBrains.gitignore
+# and can be added to the global gitignore or merged into this file. For a more nuclear
+# option (not recommended) you can uncomment the following to ignore the entire idea folder.
+#.idea/
+#.vscode/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..073f5c6109aa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Ed <me at edzz dot de>
+pkgname=pgxman
+pkgver=1.0.1
+pkgrel=1
+pkgdesc='PostgreSQL Extension Manager'
+arch=('x86_64')
+url="https://pgxman.com/"
+license=('FSL-1.0-Apache-2.0')
+makedepends=('go')
+source=("https://github.com/$pkgname/$pkgname/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('71f0986df8922df67fe20122776d6d46e7877233e3c52df3761f86d364c77a66')
+
+prepare(){
+ cd "$pkgname-$pkgver"
+ mkdir -p build/
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+ go build -o build/pgxman ./cmd/pgxman
+ go build -o build/pgxman-pack ./cmd/pgxman-pack
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ go test $(go list ./... | grep -v e2etest) -count=1 -v
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 build/pgxman "$pkgdir"/usr/bin/pgxman
+ install -Dm755 build/pgxman-pack "$pkgdir"/usr/bin/pgxman-pack
+}
+