summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKonstantin Shalygin2016-03-18 11:03:51 +0600
committerKonstantin Shalygin2016-03-18 11:03:51 +0600
commiteb7f2d1fa0143cd99c04437d1dce1bc52fc4a56f (patch)
tree2941622d551e83480614b930ae3b3cfb71d5897f
downloadaur-eb7f2d1fa0143cd99c04437d1dce1bc52fc4a56f.tar.gz
Recovered package from AUR3, fixed to build with GCC 5
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD31
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1cee24d3d2bd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Fri Mar 18 05:03:41 UTC 2016
+pkgbase = phantom
+ pkgdesc = Scalable I/O engine
+ pkgver = r17.46aa170
+ pkgrel = 1
+ url = https://github.com/k0ste/phantom
+ arch = i686
+ arch = x86_64
+ license = LGPL2.1
+ makedepends = git
+ makedepends = gcc-multilib
+ depends = openssl
+ source = phantom::git+https://github.com/k0ste/phantom.git
+ sha256sums = SKIP
+
+pkgname = phantom
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ea3495cd5e07
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/*
+src/*
+*.tar.*
+phantom/* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5408b33eeca7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Konstantin Shalygin <k0ste@cn.ru>
+
+pkgname='phantom'
+pkgver=r17.46aa170
+pkgrel=1
+pkgdesc='Scalable I/O engine'
+arch=('i686' 'x86_64')
+url="https://github.com/k0ste/${pkgname}"
+license=('LGPL2.1')
+depends=('openssl')
+makedepends=('git' 'gcc-multilib')
+source=("${pkgname}::git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build(){
+ cd "${srcdir}/${pkgname}"
+ make -R all
+}
+
+package(){
+ pushd "${srcdir}/${pkgname}"
+ install -d "${pkgdir}/usr/bin" "${pkgdir}/usr/lib/${pkgname}"
+ install -Dm775 "bin/${pkgname}" "${pkgdir}/usr/bin"
+ install -Dm644 "lib/${pkgname}/"*.so "${pkgdir}/usr/lib/${pkgname}"
+ popd
+}