summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYen Chi Hsuan2018-01-24 22:24:44 +0800
committerYen Chi Hsuan2018-01-24 22:24:44 +0800
commit0d82ca0b17f9ddbe37e5679ace43697eb789fbb4 (patch)
treeb6da81cbf9ea1bcbf0d6c8edb1aa516664829c18
downloadaur-0d82ca0b17f9ddbe37e5679ace43697eb789fbb4.tar.gz
Recreate the package from [community]
https://git.archlinux.org/svntogit/community.git/commit/?id=ae6ac0fcd8d5c8e4d4dfd0d70a7194c34e0cac93
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD48
-rw-r--r--icu59.patch38
3 files changed, 112 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..340670ccc1a0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = phantomjs
+ pkgdesc = Headless WebKit with JavaScript API
+ pkgver = 2.1.1
+ pkgrel = 9
+ url = http://www.phantomjs.org/
+ arch = i686
+ arch = x86_64
+ license = BSD
+ license = LGPL
+ license = MIT
+ makedepends = git
+ depends = icu
+ depends = libjpeg-turbo
+ depends = libpng
+ depends = fontconfig
+ depends = gperf
+ depends = ruby
+ depends = python2
+ depends = openssl-1.0
+ source = git+https://github.com/ariya/phantomjs.git#tag=2.1.1
+ source = icu59.patch
+ sha512sums = SKIP
+ sha512sums = e349a14c5d32e5627f28be6ebd20104370ec6b7f086f670e7f19b484b38839220cfeb49178765f38d918d05fb889bbc990f8a3809db6d9e1cbde0af5b9dd923b
+
+pkgname = phantomjs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cc16c1a92da9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# $Id$
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+# Contributor: grimsock <lord.grimsock at gmail dot com>
+# Contributor: Dieter Plaetinck <dieter@plaetinck.be>
+# Contributor: Vladimir Chizhov <jagoterr@gmail.com>
+# Contributor: Henry Tang <henryykt@gmail.com>
+
+pkgname=phantomjs
+pkgver=2.1.1
+pkgrel=9
+pkgdesc="Headless WebKit with JavaScript API"
+url="http://www.phantomjs.org/"
+license=('BSD' 'LGPL' 'MIT')
+arch=('i686' 'x86_64')
+depends=('icu' 'libjpeg-turbo' 'libpng' 'fontconfig' 'gperf' 'ruby' 'python2' 'openssl-1.0')
+makedepends=('git')
+source=("git+https://github.com/ariya/${pkgname}.git#tag=$pkgver"
+ icu59.patch)
+sha512sums=('SKIP'
+ 'e349a14c5d32e5627f28be6ebd20104370ec6b7f086f670e7f19b484b38839220cfeb49178765f38d918d05fb889bbc990f8a3809db6d9e1cbde0af5b9dd923b')
+
+prepare() {
+ cd $pkgname
+ git submodule update --init
+ patch -Np1 -d src/qt/qtwebkit <../icu59.patch
+ mkdir "$srcdir/python2-path"
+ ln -s /usr/bin/python2 "$srcdir/python2-path/python"
+}
+
+build() {
+ cd $pkgname
+ export PATH="$srcdir/python2-path:$PATH" PYTHON=/usr/bin/python2
+ export CXXFLAGS+=" -I/usr/include/openssl-1.0"
+ export OPENSSL_LIBS='-L/usr/lib/openssl-1.0 -lssl -lcrypto'
+
+ python2 build.py --confirm --release --qt-config='-no-rpath'
+}
+
+package() {
+ install -Dm755 "$srcdir/$pkgname/bin/phantomjs" "$pkgdir/usr/bin/phantomjs"
+
+ mkdir -p "$pkgdir/usr/share/$pkgname"
+ cp -r "$srcdir/$pkgname/examples" "$pkgdir/usr/share/$pkgname"/
+
+ install -Dm644 "$srcdir/$pkgname/LICENSE.BSD" "$pkgdir/usr/share/licenses/$pkgname/LICENSE.BSD"
+ install -Dm644 "$srcdir/$pkgname/third-party.txt" "$pkgdir/usr/share/licenses/$pkgname/third-party.txt"
+}
+
diff --git a/icu59.patch b/icu59.patch
new file mode 100644
index 000000000000..a7c190e61f17
--- /dev/null
+++ b/icu59.patch
@@ -0,0 +1,38 @@
+--- qtwebkit-opensource-src-5.5.1/Source/JavaScriptCore/API/JSStringRef.h.orig 2015-10-13 06:37:10.000000000 +0200
++++ qtwebkit-opensource-src-5.5.1/Source/JavaScriptCore/API/JSStringRef.h 2017-04-24 12:26:42.495345570 +0200
+@@ -32,6 +32,7 @@
+ #include <stdbool.h>
+ #endif
+ #include <stddef.h> /* for size_t */
++#include <uchar.h>
+
+ #ifdef __cplusplus
+ extern "C" {
+@@ -43,7 +44,7 @@
+ @typedef JSChar
+ @abstract A Unicode character.
+ */
+- typedef unsigned short JSChar;
++ typedef char16_t JSChar;
+ #else
+ typedef wchar_t JSChar;
+ #endif
+--- qtwebkit-opensource-src-5.5.1/Source/WebKit2/Shared/API/c/WKString.h.orig 2015-10-13 06:37:12.000000000 +0200
++++ qtwebkit-opensource-src-5.5.1/Source/WebKit2/Shared/API/c/WKString.h 2017-04-24 12:27:33.432011867 +0200
+@@ -31,6 +31,7 @@
+ #ifndef __cplusplus
+ #include <stdbool.h>
+ #endif
++#include <uchar.h>
+
+ #ifdef __cplusplus
+ extern "C" {
+@@ -38,7 +39,7 @@
+
+ #if !defined(WIN32) && !defined(_WIN32) \
+ && !((defined(__CC_ARM) || defined(__ARMCC__)) && !defined(__linux__)) /* RVCT */
+- typedef unsigned short WKChar;
++ typedef char16_t WKChar;
+ #else
+ typedef wchar_t WKChar;
+ #endif