summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGoliathLabs2020-07-04 13:23:59 +0200
committerGoliathLabs2020-07-04 13:23:59 +0200
commit313c3c3e73242bf2c17ce1b14c7e6dbfe1a9695a (patch)
tree9a2ca46265a93a27ab6508b551b5ec969d8831bf
parentb46dc9ffc16f01c073f2f9cb5299e930c74dd18e (diff)
downloadaur-313c3c3e73242bf2c17ce1b14c7e6dbfe1a9695a.tar.gz
Updated: PKGBUILD
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD41
-rw-r--r--fix-missing-webkit-include-files.patch23
-rw-r--r--icu59.patch38
4 files changed, 49 insertions, 67 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a644dde3ef4b..8ce56841afc6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = phantomjs
pkgdesc = Headless WebKit with JavaScript API
pkgver = 2.1.1
- pkgrel = 14
+ pkgrel = 15
url = http://www.phantomjs.org/
arch = i686
arch = x86_64
license = BSD
license = LGPL
license = MIT
- makedepends = git
+ makedepends = quilt
depends = icu
depends = libjpeg-turbo
depends = libpng
@@ -18,13 +18,11 @@ pkgbase = phantomjs
depends = python2
depends = openssl-1.0
source = phantomjs-2.1.1.tar.gz::https://github.com/ariya/phantomjs/archive/2.1.1.tar.gz
- source = phantomjs-qtbase-b5cc0083a5766e773885e8dd624c51a967c17de0.tar.gz::https://github.com/Vitallium/qtbase/archive/b5cc0083a5766e773885e8dd624c51a967c17de0.tar.gz
- source = phantomjs-qtwebkit-e7b74331d695bfa8b77e39cdc50fc2d84a49a22a.tar.gz::https://github.com/Vitallium/qtwebkit/archive/e7b74331d695bfa8b77e39cdc50fc2d84a49a22a.tar.gz
- source = icu59.patch
+ source = https://deb.debian.org/debian/pool/main/p/phantomjs/phantomjs_2.1.1+dfsg-2.debian.tar.xz
+ source = fix-missing-webkit-include-files.patch
sha512sums = 07b769133957c5194c9afdaa347bd9a019ebe47653f98adf17a35d3dd12714d2f8e3773ced91d7d99f31cb18d7f73167022d5b0a3906d9aac0732ef96341f5ec
- sha512sums = bdbe5fe69a5b0348632cfc9cd21c49c7334c34ecf9a603e3f94d3f456e6327b3036c00a05d37f064d49788ae062adfcf25f2258083d3099f7ee1ce6d3ed813e8
- sha512sums = 232f7060509a6615a2cd4fe71f22b32cf4b25f32a46d4dc3fa9e22d8c396c90389aabb63d43c76005bb779820f5d5555dbeb0d30054e1780619e0efd1807b272
- sha512sums = e349a14c5d32e5627f28be6ebd20104370ec6b7f086f670e7f19b484b38839220cfeb49178765f38d918d05fb889bbc990f8a3809db6d9e1cbde0af5b9dd923b
+ sha512sums = f2dc95aa1a4c3c68b7400a068224b529d80a985911a3da5354a8eef08319cdcca21065fd470542b52132eb4f5d8fd699e58cba3e840d4662948ee290f8b22ef9
+ sha512sums = 0bb57e7f2dee65717bd58006a361556c64b92f0dfb83a7c0fa6691da8f7a3757f7da1575af5108bead5d78505e53779bd10463d928daa5031e653856aca131a8
pkgname = phantomjs
diff --git a/PKGBUILD b/PKGBUILD
index 190a92ca6257..510724f5b838 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,50 +8,49 @@
pkgname=phantomjs
pkgver=2.1.1
-pkgrel=14
+_debver=2.1.1+dfsg
+_debrel=2
+pkgrel=15
pkgdesc='Headless WebKit with JavaScript API'
url='http://www.phantomjs.org/'
license=('BSD' 'LGPL' 'MIT')
arch=('i686' 'x86_64')
depends=('icu' 'libjpeg-turbo' 'libpng' 'fontconfig' 'gperf' 'ruby' 'python2' 'openssl-1.0')
-makedepends=('git')
-_qtbase_commit=b5cc0083a5766e773885e8dd624c51a967c17de0
-_qtwebkit_commit=e7b74331d695bfa8b77e39cdc50fc2d84a49a22a
-source=("$pkgname-$pkgver.tar.gz"::"https://github.com/ariya/phantomjs/archive/$pkgver.tar.gz"
- "$pkgname-qtbase-$_qtbase_commit.tar.gz"::"https://github.com/Vitallium/qtbase/archive/$_qtbase_commit.tar.gz"
- "$pkgname-qtwebkit-$_qtwebkit_commit.tar.gz"::"https://github.com/Vitallium/qtwebkit/archive/$_qtwebkit_commit.tar.gz"
- icu59.patch)
+makedepends=('quilt')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/ariya/phantomjs/archive/${pkgver}.tar.gz"
+ "https://deb.debian.org/debian/pool/main/p/phantomjs/phantomjs_$_debver-$_debrel.debian.tar.xz"
+ fix-missing-webkit-include-files.patch)
sha512sums=('07b769133957c5194c9afdaa347bd9a019ebe47653f98adf17a35d3dd12714d2f8e3773ced91d7d99f31cb18d7f73167022d5b0a3906d9aac0732ef96341f5ec'
- 'bdbe5fe69a5b0348632cfc9cd21c49c7334c34ecf9a603e3f94d3f456e6327b3036c00a05d37f064d49788ae062adfcf25f2258083d3099f7ee1ce6d3ed813e8'
- '232f7060509a6615a2cd4fe71f22b32cf4b25f32a46d4dc3fa9e22d8c396c90389aabb63d43c76005bb779820f5d5555dbeb0d30054e1780619e0efd1807b272'
- 'e349a14c5d32e5627f28be6ebd20104370ec6b7f086f670e7f19b484b38839220cfeb49178765f38d918d05fb889bbc990f8a3809db6d9e1cbde0af5b9dd923b')
+ 'f2dc95aa1a4c3c68b7400a068224b529d80a985911a3da5354a8eef08319cdcca21065fd470542b52132eb4f5d8fd699e58cba3e840d4662948ee290f8b22ef9'
+ '0bb57e7f2dee65717bd58006a361556c64b92f0dfb83a7c0fa6691da8f7a3757f7da1575af5108bead5d78505e53779bd10463d928daa5031e653856aca131a8')
prepare() {
cd $pkgname-$pkgver
+ if [[ ${pkgver%.*} = ${_debver%.*} ]]; then
+ # Debian patches
+ export QUILT_PATCHES=debian/patches
+ export QUILT_REFRESH_ARGS='-p ab --no-timestamps --no-index'
+ export QUILT_DIFF_ARGS='--no-timestamps'
- rmdir src/qt/qt{base,webkit}
- mv ../qtbase-$_qtbase_commit src/qt/qtbase
- mv ../qtwebkit-$_qtwebkit_commit src/qt/qtwebkit
- # Make qt build like a git clone
- # https://bugreports.qt.io/browse/QTBUG-32397
- mkdir src/qt/qt{base,webkit}/.git
+ mv "$srcdir"/debian .
- patch -Np1 -d src/qt/qtwebkit <../icu59.patch
+ quilt push -av
+ fi
mkdir "$srcdir/python2-path"
ln -s /usr/bin/python2 "$srcdir/python2-path/python"
+ patch -p1 -i ../fix-missing-webkit-include-files.patch
}
build() {
cd $pkgname-$pkgver
- export PATH="$srcdir/python2-path:$PATH"
- export PYTHON=/usr/bin/python2
+ export PATH="$srcdir/python2-path:$PATH" PYTHON=/usr/bin/python2
export CXXFLAGS+=' -I/usr/include/openssl-1.0'
export OPENSSL_LIBS='-L/usr/lib/openssl-1.0 -lssl -lcrypto'
CFLAGS+=' -Wno-expansion-to-defined'
CXXFLAGS+=' -Wno-expansion-to-defined'
- python2 build.py --confirm --release --qt-config='-no-rpath' --qt-config='-verbose'
+ python2 build.py --skip-git --skip-qtbase --skip-qtwebkit --confirm --release
}
package() {
diff --git a/fix-missing-webkit-include-files.patch b/fix-missing-webkit-include-files.patch
new file mode 100644
index 000000000000..9e1fe8aaccb9
--- /dev/null
+++ b/fix-missing-webkit-include-files.patch
@@ -0,0 +1,23 @@
+diff --git a/src/webpage.cpp b/src/webpage.cpp
+index fc235bc..2151e4e 100644
+--- a/src/webpage.cpp
++++ b/src/webpage.cpp
+@@ -45,12 +45,12 @@
+ #include <QNetworkRequest>
+ #include <QPainter>
+ #include <QtPrintSupport/QPrinter>
+-#include <QWebHistory>
+-#include <QWebHistoryItem>
+-#include <QWebElement>
+-#include <QWebFrame>
+-#include <QWebPage>
+-#include <QWebInspector>
++#include <QtWebKit/QWebHistory>
++#include <QtWebKit/QWebHistoryItem>
++#include <QtWebKit/QWebElement>
++#include <QtWebKitWidgets/QWebFrame>
++#include <QtWebKitWidgets/QWebPage>
++#include <QtWebKitWidgets/QWebInspector>
+ #include <QMapIterator>
+ #include <QBuffer>
+ #include <QDebug>
diff --git a/icu59.patch b/icu59.patch
deleted file mode 100644
index a7c190e61f17..000000000000
--- a/icu59.patch
+++ /dev/null
@@ -1,38 +0,0 @@
---- qtwebkit-opensource-src-5.5.1/Source/JavaScriptCore/API/JSStringRef.h.orig 2015-10-13 06:37:10.000000000 +0200
-+++ qtwebkit-opensource-src-5.5.1/Source/JavaScriptCore/API/JSStringRef.h 2017-04-24 12:26:42.495345570 +0200
-@@ -32,6 +32,7 @@
- #include <stdbool.h>
- #endif
- #include <stddef.h> /* for size_t */
-+#include <uchar.h>
-
- #ifdef __cplusplus
- extern "C" {
-@@ -43,7 +44,7 @@
- @typedef JSChar
- @abstract A Unicode character.
- */
-- typedef unsigned short JSChar;
-+ typedef char16_t JSChar;
- #else
- typedef wchar_t JSChar;
- #endif
---- qtwebkit-opensource-src-5.5.1/Source/WebKit2/Shared/API/c/WKString.h.orig 2015-10-13 06:37:12.000000000 +0200
-+++ qtwebkit-opensource-src-5.5.1/Source/WebKit2/Shared/API/c/WKString.h 2017-04-24 12:27:33.432011867 +0200
-@@ -31,6 +31,7 @@
- #ifndef __cplusplus
- #include <stdbool.h>
- #endif
-+#include <uchar.h>
-
- #ifdef __cplusplus
- extern "C" {
-@@ -38,7 +39,7 @@
-
- #if !defined(WIN32) && !defined(_WIN32) \
- && !((defined(__CC_ARM) || defined(__ARMCC__)) && !defined(__linux__)) /* RVCT */
-- typedef unsigned short WKChar;
-+ typedef char16_t WKChar;
- #else
- typedef wchar_t WKChar;
- #endif