summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChih-Hsuan Yen2018-08-13 13:07:54 +0800
committerChih-Hsuan Yen2018-08-13 13:07:54 +0800
commit870537f1794764f0024cc4d6af6b715446dea625 (patch)
treec0c01f840e4eb854fb580a3d325390e8263a9e8c
parent0e04ed4201d2209314e7b5db921d0a875dc48068 (diff)
downloadaur-870537f1794764f0024cc4d6af6b715446dea625.tar.gz
use tarballs and misc changes
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD59
2 files changed, 47 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 33c64196a468..b35db27886f1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = phantomjs
pkgdesc = Headless WebKit with JavaScript API
pkgver = 2.1.1
- pkgrel = 11
+ pkgrel = 12
url = http://www.phantomjs.org/
arch = i686
arch = x86_64
@@ -9,7 +9,7 @@ pkgbase = phantomjs
license = LGPL
license = MIT
makedepends = git
- depends = icu>=61
+ depends = icu
depends = libjpeg-turbo
depends = libpng
depends = fontconfig
@@ -17,9 +17,13 @@ pkgbase = phantomjs
depends = ruby
depends = python2
depends = openssl-1.0
- source = git+https://github.com/ariya/phantomjs.git#tag=2.1.1
+ source = phantomjs-2.1.1.tar.gz::https://github.com/ariya/phantomjs/archive/2.1.1.tar.gz
+ source = phantomjs-qtbase-b5cc0083a5766e773885e8dd624c51a967c17de0.tar.gz::https://github.com/Vitallium/qtbase/archive/b5cc0083a5766e773885e8dd624c51a967c17de0.tar.gz
+ source = phantomjs-qtwebkit-e7b74331d695bfa8b77e39cdc50fc2d84a49a22a.tar.gz::https://github.com/Vitallium/qtwebkit/archive/e7b74331d695bfa8b77e39cdc50fc2d84a49a22a.tar.gz
source = icu59.patch
- sha512sums = SKIP
+ sha512sums = 07b769133957c5194c9afdaa347bd9a019ebe47653f98adf17a35d3dd12714d2f8e3773ced91d7d99f31cb18d7f73167022d5b0a3906d9aac0732ef96341f5ec
+ sha512sums = bdbe5fe69a5b0348632cfc9cd21c49c7334c34ecf9a603e3f94d3f456e6327b3036c00a05d37f064d49788ae062adfcf25f2258083d3099f7ee1ce6d3ed813e8
+ sha512sums = 232f7060509a6615a2cd4fe71f22b32cf4b25f32a46d4dc3fa9e22d8c396c90389aabb63d43c76005bb779820f5d5555dbeb0d30054e1780619e0efd1807b272
sha512sums = e349a14c5d32e5627f28be6ebd20104370ec6b7f086f670e7f19b484b38839220cfeb49178765f38d918d05fb889bbc990f8a3809db6d9e1cbde0af5b9dd923b
pkgname = phantomjs
diff --git a/PKGBUILD b/PKGBUILD
index abcd9a62e988..aef5871828fc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
-# $Id$
-# Maintainer: Felix Yan <felixonmars@archlinux.org>
+# Maintainer: Chih-Hsuan Yen <yan12125@gmail.com>
+# Contributor: Felix Yan <felixonmars@archlinux.org>
# Contributor: grimsock <lord.grimsock at gmail dot com>
# Contributor: Dieter Plaetinck <dieter@plaetinck.be>
# Contributor: Vladimir Chizhov <jagoterr@gmail.com>
@@ -7,45 +7,64 @@
pkgname=phantomjs
pkgver=2.1.1
-pkgrel=11
-pkgdesc="Headless WebKit with JavaScript API"
-url="http://www.phantomjs.org/"
+pkgrel=12
+pkgdesc='Headless WebKit with JavaScript API'
+url='http://www.phantomjs.org/'
license=('BSD' 'LGPL' 'MIT')
arch=('i686' 'x86_64')
-depends=('icu>=61' 'libjpeg-turbo' 'libpng' 'fontconfig' 'gperf' 'ruby' 'python2' 'openssl-1.0')
+depends=('icu' 'libjpeg-turbo' 'libpng' 'fontconfig' 'gperf' 'ruby' 'python2' 'openssl-1.0')
makedepends=('git')
-source=("git+https://github.com/ariya/${pkgname}.git#tag=$pkgver"
+_qtbase_commit=b5cc0083a5766e773885e8dd624c51a967c17de0
+_qtwebkit_commit=e7b74331d695bfa8b77e39cdc50fc2d84a49a22a
+source=("$pkgname-$pkgver.tar.gz"::"https://github.com/ariya/phantomjs/archive/$pkgver.tar.gz"
+ "$pkgname-qtbase-$_qtbase_commit.tar.gz"::"https://github.com/Vitallium/qtbase/archive/$_qtbase_commit.tar.gz"
+ "$pkgname-qtwebkit-$_qtwebkit_commit.tar.gz"::"https://github.com/Vitallium/qtwebkit/archive/$_qtwebkit_commit.tar.gz"
icu59.patch)
-sha512sums=('SKIP'
+sha512sums=('07b769133957c5194c9afdaa347bd9a019ebe47653f98adf17a35d3dd12714d2f8e3773ced91d7d99f31cb18d7f73167022d5b0a3906d9aac0732ef96341f5ec'
+ 'bdbe5fe69a5b0348632cfc9cd21c49c7334c34ecf9a603e3f94d3f456e6327b3036c00a05d37f064d49788ae062adfcf25f2258083d3099f7ee1ce6d3ed813e8'
+ '232f7060509a6615a2cd4fe71f22b32cf4b25f32a46d4dc3fa9e22d8c396c90389aabb63d43c76005bb779820f5d5555dbeb0d30054e1780619e0efd1807b272'
'e349a14c5d32e5627f28be6ebd20104370ec6b7f086f670e7f19b484b38839220cfeb49178765f38d918d05fb889bbc990f8a3809db6d9e1cbde0af5b9dd923b')
prepare() {
- cd $pkgname
- git submodule update --init
+ cd $pkgname-$pkgver
+
+ rmdir src/qt/qt{base,webkit}
+ ln -s ../../../qtbase-$_qtbase_commit src/qt/qtbase
+ ln -s ../../../qtwebkit-$_qtwebkit_commit src/qt/qtwebkit
+
patch -Np1 -d src/qt/qtwebkit <../icu59.patch
mkdir "$srcdir/python2-path"
ln -s /usr/bin/python2 "$srcdir/python2-path/python"
+
+ # syncqt creates forwarded header files (include/QtCore/...). Normally, it's
+ # run in git checkouts and skipped in stable versions as forwarded headers
+ # are pre-generated. In this package, Qt mistakenly thinks this is a stable
+ # version as .git is missing, so we need to run this command manually.
+ cd src/qt/qtbase
+ ./bin/syncqt.pl -minimal -module QtCore "$srcdir/$pkgname-$pkgver/src/qt/qtbase"
}
build() {
- cd $pkgname
- export PATH="$srcdir/python2-path:$PATH" PYTHON=/usr/bin/python2
- export CXXFLAGS+=" -I/usr/include/openssl-1.0"
+ cd $pkgname-$pkgver
+ export PATH="$srcdir/python2-path:$PATH"
+ export PYTHON=/usr/bin/python2
+ export CXXFLAGS+=' -I/usr/include/openssl-1.0'
export OPENSSL_LIBS='-L/usr/lib/openssl-1.0 -lssl -lcrypto'
- CFLAGS+=" -Wno-expansion-to-defined"
- CXXFLAGS+=" -Wno-expansion-to-defined"
+ CFLAGS+=' -Wno-expansion-to-defined'
+ CXXFLAGS+=' -Wno-expansion-to-defined'
- python2 build.py --confirm --release --qt-config='-no-rpath'
+ python2 build.py --confirm --release --qt-config='-no-rpath' --qt-config='-verbose'
}
package() {
- install -Dm755 "$srcdir/$pkgname/bin/phantomjs" "$pkgdir/usr/bin/phantomjs"
+ cd $pkgname-$pkgver
+ install -Dm755 bin/phantomjs "$pkgdir/usr/bin/phantomjs"
mkdir -p "$pkgdir/usr/share/$pkgname"
- cp -r "$srcdir/$pkgname/examples" "$pkgdir/usr/share/$pkgname"/
+ cp -r examples "$pkgdir/usr/share/$pkgname/"
- install -Dm644 "$srcdir/$pkgname/LICENSE.BSD" "$pkgdir/usr/share/licenses/$pkgname/LICENSE.BSD"
- install -Dm644 "$srcdir/$pkgname/third-party.txt" "$pkgdir/usr/share/licenses/$pkgname/third-party.txt"
+ install -Dm644 LICENSE.BSD "$pkgdir/usr/share/licenses/$pkgname/LICENSE.BSD"
+ install -Dm644 third-party.txt "$pkgdir/usr/share/licenses/$pkgname/third-party.txt"
}