summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Bonifati2018-01-30 18:32:11 +0100
committerAntonio Bonifati2018-01-30 18:32:11 +0100
commitf195711434bf30f008addd1161afb72c3f4727ab (patch)
treef6f1f1d7c8603b16fa386e22bfd5de9d9405c077
downloadaur-f195711434bf30f008addd1161afb72c3f4727ab.tar.gz
New phantomjs binary package, latest stable version
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD24
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..139bfe58bd41
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = phantomjs-bin
+ pkgdesc = Headless WebKit with JavaScript API (official static binary)
+ pkgver = 2.1.3
+ pkgrel = 1
+ url = http://www.phantomjs.org/
+ arch = x86_64
+ license = BSD
+ depends = fontconfig
+ depends = icu55
+ provides = phantomjs
+ conflicts = phantomjs
+ options = !strip
+ source = https://github.com/ariya/phantomjs/releases/download/2.1.3/phantomjs
+ md5sums = 4c5fd62ccc91c482f2151f435cf57e6b
+
+pkgname = phantomjs-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ebe8aa102456
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Antonio Bonifati <antonio[dot]bonifati(SLUG)gmail[stitch]com>
+# Contributor: Franklyn Tackitt <franklyn+aur@tackitt.net>
+# Contributor: Jochen Schalanda <jochen+aur@schalanda.name>
+# Contributor: Marcel Korpel <marcel[dot]korpel[at]gmail.com>
+
+_pkgname=phantomjs
+_pkgver=2.1.3
+pkgname=${_pkgname}-bin
+pkgver=${_pkgver}
+pkgrel=1
+pkgdesc="Headless WebKit with JavaScript API (official static binary)"
+url="http://www.phantomjs.org/"
+license=("BSD")
+arch=('x86_64')
+depends=('fontconfig' 'icu55')
+conflicts=('phantomjs')
+provides=('phantomjs')
+options=('!strip')
+source=("https://github.com/ariya/phantomjs/releases/download/${_pkgver}/${_pkgname}")
+md5sums=('4c5fd62ccc91c482f2151f435cf57e6b')
+
+package() {
+ install -Dm755 "$srcdir/${_pkgname}" "$pkgdir/usr/bin/phantomjs"
+}