summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordetiam2023-04-05 10:16:43 +0800
committerdetiam2023-04-05 10:16:43 +0800
commit8ca8ea282a95c312b7b8d5d103f16d03c70a2150 (patch)
tree4dd9acd3c6e4f60f6e8bced58312e998e6da642d
parentad8fccd9304b61db49f229d8f144f783099c1f3e (diff)
downloadaur-8ca8ea282a95c312b7b8d5d103f16d03c70a2150.tar.gz
pcap default
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3716b7c0ed4d..c7098cd37f12 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,19 +2,19 @@ pkgbase = phantomsocks-git
pkgdesc = A cross-platform proxy client/server for Linux/Windows/macOS
pkgver = r282.3c556b0
pkgrel = 1
- url = https://github.com/macronut/phantomsocks
+ url = https://github.com/detiam/phantomsocks
arch = i686
arch = x86_64
license = LGPL-3.0
makedepends = go
makedepends = git
+ makedepends = libpcap
depends = systemd
optdepends = v2raya: for use with v2raya
- optdepends = libpcap: you can build pcap version if you want, see PKGBUILD build()
provides = phantomsocks
conflicts = phantomsocks
replaces = phantomsocks
- source = git+https://github.com/macronut/phantomsocks
+ source = git+https://github.com/detiam/phantomsocks
source = phantomsocks.sysusers
source = phantomsocks.service
source = phantomsocks@.service
diff --git a/PKGBUILD b/PKGBUILD
index bfbc969ebbe6..9ae41bfb8a59 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,16 +7,16 @@ pkgrel=1
epoch=
pkgdesc="A cross-platform proxy client/server for Linux/Windows/macOS"
arch=(i686 x86_64)
-url="https://github.com/macronut/$_pkgname"
+url="https://github.com/detiam/$_pkgname"
#_commit=a521259ffc1cfd8753845997c09644b976af2d6c
license=('LGPL-3.0')
groups=()
depends=('systemd')
-makedepends=('go' 'git')
+makedepends=('go' 'git' 'libpcap')
checkdepends=()
optdepends=(
'v2raya: for use with v2raya'
- 'libpcap: you can build pcap version if you want, see PKGBUILD build()'
+ #'libpcap: you can build pcap version if you want, see PKGBUILD build()'
)
provides=("$_pkgname")
conflicts=("$_pkgname")
@@ -28,8 +28,8 @@ changelog=
source=(
"git+$url"
"$_pkgname.sysusers"
- "$_pkgname.service"
- "$_pkgname@.service"
+ "$_pkgname.service"
+ "$_pkgname@.service"
)
noextract=()
md5sums=('SKIP' 'SKIP' 'SKIP' 'SKIP')
@@ -46,8 +46,8 @@ pkgver() {
build() {
cd "$_pkgname"
# Choose between them
- go build -tags rawsocket
- #go build -tags pcap
+ #go build -tags rawsocket
+ go build -tags pcap
}
package() {