summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-03-29 12:32:09 +0800
committerzxp198210052024-03-29 12:32:09 +0800
commit7f89169a4ce7b7f95ce98f836a93d7c03086737f (patch)
treec10eda3310b1882b65c660b290fa8071f8548b80
downloadaur-7f89169a4ce7b7f95ce98f836a93d7c03086737f.tar.gz
update to 1.4.1
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD46
-rw-r--r--pharmaspot.sh16
3 files changed, 84 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..029e8bebafa8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = pharmaspot-bin
+ pkgdesc = A cross-platform Point of Sale system designed for pharmacies and built to streamline operations and enhance customer service.
+ pkgver = 1.4.1
+ pkgrel = 1
+ url = https://github.com/drkNsubuga/PharmaSpot
+ arch = x86_64
+ license = MIT
+ makedepends = gendesk
+ depends = electron22
+ provides = pharmaspot=1.4.1
+ conflicts = pharmaspot
+ options = !emptydirs
+ source = pharmaspot-1.4.1.zip::https://github.com/drkNsubuga/PharmaSpot/releases/download/v1.4.1/Pharmaspot-linux-x64-1.4.1.zip
+ source = LICENSE-1.4.1::https://raw.githubusercontent.com/drkNsubuga/PharmaSpot/v1.4.1/LICENSE
+ source = pharmaspot-1.4.1.png::https://raw.githubusercontent.com/drkNsubuga/PharmaSpot/v1.4.1/assets/images/favicon.png
+ source = pharmaspot.sh
+ sha256sums = 4814c7009534caa7b22a46da33f6551f237a077d987a695eb7eb57756c849c49
+ sha256sums = 66d59240c025ee617d78f981b88b1bb53393e657f064f9e8e0d68204644d8e1c
+ sha256sums = ba44229f6c0a35bb02fe584adb1b33029c78a80b2bdb96877ddff05c3b6ac17a
+ sha256sums = dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8
+
+pkgname = pharmaspot-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9b11c83d3858
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
+pkgname=pharmaspot-bin
+_pkgname=Pharmaspot
+pkgver=1.4.1
+_electronversion=22
+pkgrel=1
+pkgdesc="A cross-platform Point of Sale system designed for pharmacies and built to streamline operations and enhance customer service."
+arch=("x86_64")
+url="https://github.com/drkNsubuga/PharmaSpot"
+license=('MIT')
+provides=("${pkgname%-bin}=${pkgver}")
+conflicts=("${pkgname%-bin}")
+depends=(
+ "electron${_electronversion}"
+)
+makedepends=(
+ 'gendesk'
+)
+options=(
+ '!emptydirs'
+)
+source=(
+ "${pkgname%-bin}-${pkgver}.zip::${url}/releases/download/v${pkgver}/${_pkgname}-linux-x64-${pkgver}.zip"
+ "LICENSE-${pkgver}::https://raw.githubusercontent.com/drkNsubuga/PharmaSpot/v${pkgver}/LICENSE"
+ "${pkgname%-bin}-${pkgver}.png::https://raw.githubusercontent.com/drkNsubuga/PharmaSpot/v${pkgver}/assets/images/favicon.png"
+ "${pkgname%-bin}.sh"
+)
+sha256sums=('4814c7009534caa7b22a46da33f6551f237a077d987a695eb7eb57756c849c49'
+ '66d59240c025ee617d78f981b88b1bb53393e657f064f9e8e0d68204644d8e1c'
+ 'ba44229f6c0a35bb02fe584adb1b33029c78a80b2bdb96877ddff05c3b6ac17a'
+ 'dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
+build() {
+ sed -e "s|@electronversion@|${_electronversion}|" \
+ -e "s|@appname@|${pkgname%-bin}|g" \
+ -e "s|@runname@|app|g" \
+ -e "s|@options@||g" \
+ -i "${srcdir}/${pkgname%-bin}.sh"
+ gendesk -q -f -n --categories="Utility" --name="${_pkgname}" --exec="${pkgname%-bin} %U"
+}
+package() {
+ install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/${_pkgname%-bin}-linux-x64/resources/app.asar" -t "${pkgdir}/usr/lib/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/LICENSE-${pkgver}" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 "${srcdir}/${pkgname%-bin}-${pkgver}.png" "${pkgdir}/usr/share/pixmaps/${pkgname%-bin}.png"
+ install -Dm644 "${srcdir}/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
+} \ No newline at end of file
diff --git a/pharmaspot.sh b/pharmaspot.sh
new file mode 100644
index 000000000000..7ddcaab8d734
--- /dev/null
+++ b/pharmaspot.sh
@@ -0,0 +1,16 @@
+#!/bin/bash
+set -e
+_APPDIR="/usr/lib/@appname@"
+_RUNNAME="${_APPDIR}/@runname@"
+_OPTIONS="@options@"
+export PATH="${_APPDIR}:${PATH}"
+export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
+export ELECTRON_IS_DEV=0
+export ELECTRON_FORCE_IS_PACKAGED=true
+export NODE_ENV=production
+cd "${_APPDIR}"
+if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" "$@" || exit $?
+else
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" --no-sandbox "$@" || exit $?
+fi \ No newline at end of file