summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Milde2016-01-14 09:50:03 +0100
committerDaniel Milde2016-01-14 09:50:03 +0100
commit336d669baa8374718a032bfbf596797058e84238 (patch)
treef8c2b50aad32584aa448e8c36bfc18b960464cf1
parent525266aa8105e2362e120baac856bad88e63c724 (diff)
downloadaur-336d669baa8374718a032bfbf596797058e84238.tar.gz
downgrade to 4.0.626
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD17
-rwxr-xr-xpharo.sh2
3 files changed, 14 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aae242ed2742..52ab3da4b21e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pharo
pkgdesc = a fork of Squeak, an implementation of the object-oriented, dynamically typed, reflective programming language Smalltalk
- pkgver = 5.0.359
+ pkgver = 4.0.626
pkgrel = 1
url = http://www.pharo-project.org/
arch = i686
@@ -14,16 +14,16 @@ pkgbase = pharo
depends = dbus-core
depends = libxml2
source = http://files.pharo.org/vm/pharo/linux/stable.zip
- source = http://files.pharo.org/image/50/50359.zip
+ source = http://files.pharo.org/image/stable/40626.zip
source = http://files.pharo.org/media/logo/icon-512x512.png
source = http://files.pharo.org/sources/PharoV40.sources.zip
source = pharo.sh
source = pharo.desktop
sha256sums = e525ded202ac0e9f7a2db38fbe32ac07bca2d2e6ef90b17fd08f438d40a4f1f9
- sha256sums = 059ceb724adde7e8a73eca5c061d7b640cf236f7595e9a4de2741175a12e76c5
+ sha256sums = ea1e6a93bd33eb1552c1f36df5c1525a9d91da578ba23b56e85e3add265dd18f
sha256sums = 5a6f40722264a2befc9aea1dace399f2491cd45a98987458660f8a39d4e6887e
sha256sums = ed5a2c1b729c5cd5825841a4691affe81d2c121467e488f2bb30058a833801f7
- sha256sums = 3c5ec6c4807df853d3b448d867a1d369a01475015e5dabb4dfdd4a64746c1d87
+ sha256sums = d20142129bdba703fde4d7f355f516d47e284d93d4d0536a0d8d34d850a06094
sha256sums = ad37a9c7d05b72a1d0375de7b7056dfcb220e2bef6358a99b6075ae6f66905f6
pkgname = pharo
diff --git a/PKGBUILD b/PKGBUILD
index 2ac9b004e8d9..197c9bea2811 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Daniel Milde <daniel@milde.cz>
pkgname=pharo
-pkgver=5.0.359
+pkgver=4.0.626
pkgrel=1
pkgdesc="a fork of Squeak, an implementation of the object-oriented, dynamically typed, reflective programming language Smalltalk"
arch=(i686 x86_64)
@@ -15,32 +15,33 @@ else
fi
imageversion=${pkgver//./}
+vmversion=stable
-source=(http://files.pharo.org/vm/pharo/linux/stable.zip \
- http://files.pharo.org/image/50/${imageversion}.zip\
+source=(http://files.pharo.org/vm/pharo/linux/${vmversion}.zip \
+ http://files.pharo.org/image/stable/${imageversion}.zip\
http://files.pharo.org/media/logo/icon-512x512.png\
http://files.pharo.org/sources/PharoV40.sources.zip\
$pkgname.sh
$pkgname.desktop)
sha256sums=('e525ded202ac0e9f7a2db38fbe32ac07bca2d2e6ef90b17fd08f438d40a4f1f9'\
- '059ceb724adde7e8a73eca5c061d7b640cf236f7595e9a4de2741175a12e76c5'\
+ 'ea1e6a93bd33eb1552c1f36df5c1525a9d91da578ba23b56e85e3add265dd18f'\
'5a6f40722264a2befc9aea1dace399f2491cd45a98987458660f8a39d4e6887e'\
'ed5a2c1b729c5cd5825841a4691affe81d2c121467e488f2bb30058a833801f7'\
- '3c5ec6c4807df853d3b448d867a1d369a01475015e5dabb4dfdd4a64746c1d87'\
+ 'd20142129bdba703fde4d7f355f516d47e284d93d4d0536a0d8d34d850a06094'\
'ad37a9c7d05b72a1d0375de7b7056dfcb220e2bef6358a99b6075ae6f66905f6')
package() {
cd $srcdir
- unzip stable.zip -d bin
+ unzip $vmversion.zip -d bin
mkdir -p $pkgdir/opt/pharo/shared
mkdir -p $pkgdir/usr/bin
cp -R bin $pkgdir/opt/pharo
install $pkgname.sh $pkgdir/opt/pharo/pharo
- install Pharo-${imageversion}.changes $pkgdir/opt/pharo/shared/Pharo5.0.changes
- install Pharo-${imageversion}.image $pkgdir/opt/pharo/shared/Pharo5.0.image
+ install Pharo-${imageversion}.changes $pkgdir/opt/pharo/shared/Pharo4.0.changes
+ install Pharo-${imageversion}.image $pkgdir/opt/pharo/shared/Pharo4.0.image
install PharoV40.sources $pkgdir/opt/pharo/shared/PharoV40.sources
ln -s /opt/pharo/pharo $pkgdir/usr/bin/pharo
diff --git a/pharo.sh b/pharo.sh
index 1727fc1b9680..ba8afd213514 100755
--- a/pharo.sh
+++ b/pharo.sh
@@ -21,7 +21,7 @@ if [ "$1" == "" ]; then
if which zenity &>/dev/null && [ "$image_count" -ne 1 ]; then
image=`zenity --title 'Select an image' --file-selection --filename "$RESOURCES/" --file-filter '*.image' --file-filter '*'`
else
- image="$RESOURCES/Pharo5.0.image"
+ image="$RESOURCES/Pharo4.0.image"
fi
else
image=$*