summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlvaro Fernando García2020-03-15 21:54:36 -0300
committerAlvaro Fernando García2020-03-15 21:54:36 -0300
commit35e0d21276d788e760c10e9d6283c39cffdf803b (patch)
tree46f2b9092c243e7d5ec2635dbc54fdf24280cecb
downloadaur-35e0d21276d788e760c10e9d6283c39cffdf803b.tar.gz
Initial commit
-rw-r--r--.SRCINFO26
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD41
-rw-r--r--icon-512x512.pngbin0 -> 95724 bytes
-rw-r--r--pharo.desktop9
-rw-r--r--pharo.sh2
6 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..494f15b738b2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = pharo-bin
+ pkgdesc = A fork of Squeak, an implementation of the object-oriented, dynamically typed, reflective programming language Smalltalk
+ pkgver = 8.0
+ pkgrel = 1
+ url = https://pharo.org/
+ arch = x86_64
+ license = MIT
+ depends = alsa-lib
+ depends = libvorbis
+ depends = pango
+ depends = mesa
+ depends = dbus
+ depends = libxml2
+ provides = pharo
+ conflicts = pharo
+ source = https://files.pharo.org/get-files/80/pharo64-linux-stable.zip
+ source = http://files.pharo.org/media/logo/icon-512x512.png
+ source = pharo.sh
+ source = pharo.desktop
+ sha256sums = 533e786c5676ed293df8fac648a38cfb54aaa1c03d40d70036313a7c0f2a6038
+ sha256sums = 5a6f40722264a2befc9aea1dace399f2491cd45a98987458660f8a39d4e6887e
+ sha256sums = b160f1303f79255148c11c5625644cd42e5aea6e51de19ef4858c925e31baff0
+ sha256sums = 68b96be66d14a9ad129016b2b59fc73a25ca92091a5869e9ae8960470b19f273
+
+pkgname = pharo-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..292d560ee2a0
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.pkg.tar.xz
+pharo64-linux-stable.zip
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..45b7acd7d7e1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Alvaro F. García <https://rainbyte.github.io>
+# Contributor: Daniel Milde <daniel at milde dot cz>
+# Contributor: Eric Forgeot < http://anamnese.online.fr >
+
+pkgname=pharo-bin
+_pkgname=pharo
+pkgver=8.0
+pkgrel=1
+pkgdesc="A fork of Squeak, an implementation of the object-oriented, dynamically typed, reflective programming language Smalltalk"
+arch=(x86_64)
+url="https://pharo.org/"
+license=('MIT')
+depends=('alsa-lib' 'libvorbis' 'pango' 'mesa' 'dbus' 'libxml2')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+
+source=('https://files.pharo.org/get-files/80/pharo64-linux-stable.zip'
+ 'http://files.pharo.org/media/logo/icon-512x512.png'
+ "$_pkgname.sh"
+ "$_pkgname.desktop")
+
+sha256sums=('533e786c5676ed293df8fac648a38cfb54aaa1c03d40d70036313a7c0f2a6038'
+ '5a6f40722264a2befc9aea1dace399f2491cd45a98987458660f8a39d4e6887e'
+ 'b160f1303f79255148c11c5625644cd42e5aea6e51de19ef4858c925e31baff0'
+ '68b96be66d14a9ad129016b2b59fc73a25ca92091a5869e9ae8960470b19f273')
+
+package() {
+ # copy executables and libs
+ install -d "$pkgdir/opt/$_pkgname"
+ cp -R $srcdir/bin $pkgdir/opt/$_pkgname
+ cp -R $srcdir/lib $pkgdir/opt/$_pkgname
+
+ # make symlinks
+ install -Dm755 $srcdir/$_pkgname.sh $pkgdir/usr/bin/$_pkgname
+
+ # copy icons
+ install -Dm644 $srcdir/icon-512x512.png $pkgdir/usr/share/pixmaps/$pkgname.png
+
+ # copy .desktop files
+ install -Dm644 $srcdir/$_pkgname.desktop $pkgdir/usr/share/applications/$_pkgname.desktop
+}
diff --git a/icon-512x512.png b/icon-512x512.png
new file mode 100644
index 000000000000..8511dbff62fe
--- /dev/null
+++ b/icon-512x512.png
Binary files differ
diff --git a/pharo.desktop b/pharo.desktop
new file mode 100644
index 000000000000..5ace35d4443d
--- /dev/null
+++ b/pharo.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Version=8.0
+Type=Application
+Name=Pharo
+GenericName=Pharo
+Comment=An implementation of Smalltalk
+Icon=pharo.png
+Exec=pharo
+Categories=Development;
diff --git a/pharo.sh b/pharo.sh
new file mode 100644
index 000000000000..b3ae69e41187
--- /dev/null
+++ b/pharo.sh
@@ -0,0 +1,2 @@
+#!/bin/sh
+/opt/pharo/bin/pharo $@