aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenoit Verhaeghe2024-05-15 22:38:19 +0200
committerBenoit Verhaeghe2024-05-15 22:38:19 +0200
commit5a14307f2f784bdca590574317d5d2a2987d80b2 (patch)
treeff182aeb48e440b91bca06a06ded1ffb97783da9
parent20e0c0fcb6d0663c469d798517ff85f1ec237485 (diff)
downloadaur-5a14307f2f784bdca590574317d5d2a2987d80b2.tar.gz
working on icons for linux system with adaptation of script and using .desktop file
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD33
3 files changed, 25 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3055dba02e0c..6c44648fefda 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pharo-launcher
pkgdesc = Pharo Launcher helps you manage your Pharo images
pkgver = 3.1.1
- pkgrel = 1
+ pkgrel = 2
epoch = 1
url = http://www.pharo-project.org/
arch = x86_64
@@ -13,8 +13,10 @@ pkgbase = pharo-launcher
source = https://github.com/pharo-project/pharo-launcher/releases/download/3.1.1/PharoLauncher-linux-3.1.1-x64.zip
source = local://pharo.conf
source = local://launcher-patch.st
+ source = https://files.pharo.org/media/logo/icon-opaque-512x512.png
md5sums = cedba3fa83d6a80418315df8c95473ad
md5sums = b2e30a17b522ee265fd57fe7c45592fc
md5sums = c74b8fc7c1e23c60b1b2030afaead26c
+ md5sums = b8323c1d7421dce18db921ae83ff8409
pkgname = pharo-launcher
diff --git a/.gitignore b/.gitignore
index 1423defebb0c..9aaff4c07c47 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,7 +1,9 @@
src/*
pkg/*
pharo-launcher-1*
+pharo-launcher-*
PharoLauncher-linux-*
+icon-opaque*
PharoDebug.log
PharoLauncher.changes
diff --git a/PKGBUILD b/PKGBUILD
index acc371b0158f..05ef7abaf404 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,5 @@
# Maintainer: Laurent Laffont <laurent.laffont@gmail.com>
-# Maintainer: Benoit Verhaeghe <badetitou@gmail.com>
-
+# Maintainer: Benoit Verhaeghe <benoit@badetitou.fr>
pkgname=pharo-launcher
# Major version of this pkgbuild
@@ -8,7 +7,7 @@ epoch=1
# Version of Pharo Launcher
pkgver=3.1.1
# Revision of this pkgbuild
-pkgrel=1
+pkgrel=2
pkgdesc="Pharo Launcher helps you manage your Pharo images"
arch=(x86_64)
source=(PharoLauncher-linux-$pkgver.zip pharo.conf)
@@ -21,16 +20,19 @@ source=(
"https://github.com/pharo-project/pharo-launcher/releases/download/$pkgver/PharoLauncher-linux-$pkgver-x64.zip"
'local://pharo.conf'
'local://launcher-patch.st'
+ 'https://files.pharo.org/media/logo/icon-opaque-512x512.png'
)
md5sums=(
'cedba3fa83d6a80418315df8c95473ad'
'b2e30a17b522ee265fd57fe7c45592fc'
'c74b8fc7c1e23c60b1b2030afaead26c'
+ 'b8323c1d7421dce18db921ae83ff8409'
)
prepare() {
- gendesk -n -f --pkgname "$pkgname" --pkgdesc "$pkgdesc" --categories "Development" --name "Pharo Launcher"
+ gendesk -n -f --icon "pharo-launcher" --pkgname "$pkgname" --pkgdesc "$pkgdesc" --categories "Development" --name "Pharo Launcher"
+ gendesk -n -f --icon "pharo" --pkgname "pharo" --pkgdesc "A Pharo VM executed" --categories "Development" --name "Pharo" --custom="NoDisplay=true"
}
@@ -43,26 +45,31 @@ package() {
mkdir -p $pkgdir/usr/bin
- cp -fR $srcdir/pharolauncher/shared/* $pkgdir/usr/share/pharo-launcher/
+ cp -fR $srcdir/artifacts/PharoLauncher-linux-3.1.1-x64/shared/* $pkgdir/usr/share/pharo-launcher/
chmod -R 777 $pkgdir/usr/share/pharo-launcher/
- cp -fR $srcdir/pharolauncher/pharo-vm/* $pkgdir/usr/share/pharo-vm/
+ cp -fR $srcdir/artifacts/PharoLauncher-linux-3.1.1-x64/shared/pharo-vm/* $pkgdir/usr/share/pharo-vm/
+ mv $pkgdir/usr/share/pharo-vm/pharo $pkgdir/usr/share/pharo-vm/pharo-launcher
chmod -R 777 $pkgdir/usr/share/pharo-vm/
- sed -i 's/ROOT=`dirname "$DIR"`/ROOT=\/usr\/share/' $srcdir/pharolauncher/pharo-launcher
- sed -i 's/LINUX="$ROOT\/bin"/LINUX="$ROOT\/pharo"/' $srcdir/pharolauncher/pharo-launcher
- sed -i 's/RESOURCES="$ROOT\/shared"/RESOURCES="\/usr\/share\/pharo-launcher"/' $srcdir/pharolauncher/pharo-launcher
- sed -i 's/ICONS="$ROOT\/icons"/ICONS="$ROOT\/pixmaps"/' $srcdir/pharolauncher/pharo-launcher
+ sed -i 's/ROOT=`dirname "$DIR"`/ROOT=\/usr\/share/' $srcdir/artifacts/PharoLauncher-linux-3.1.1-x64/pharo-launcher
+ sed -i 's/LINUX="$ROOT\/bin"/LINUX="$ROOT\/pharo"/' $srcdir/artifacts/PharoLauncher-linux-3.1.1-x64/pharo-launcher
+ sed -i 's/RESOURCES="$ROOT\/shared"/RESOURCES="\/usr\/share\/pharo-launcher"/' $srcdir/artifacts/PharoLauncher-linux-3.1.1-x64/pharo-launcher
+ sed -i 's/ICONS="$ROOT\/icons"/ICONS="$ROOT\/pixmaps"/' $srcdir/artifacts/PharoLauncher-linux-3.1.1-x64/pharo-launcher
+ # Rename executable of the vm for the icon
+ sed -i 's/$LINUX\/pharo/$LINUX\/pharo-launcher/' $srcdir/artifacts/PharoLauncher-linux-3.1.1-x64/pharo-launcher
- cp -f $srcdir/pharolauncher/pharo-launcher $pkgdir/usr/bin/pharo-launcher
+ cp -f $srcdir/artifacts/PharoLauncher-linux-3.1.1-x64/pharo-launcher $pkgdir/usr/bin/pharo-launcher
chmod +x $pkgdir/usr/bin/pharo-launcher
- install -Dm644 $srcdir/pharolauncher/icons/pharo-launcher.png $pkgdir/usr/share/pixmaps/$pkgname.png
+ install -Dm644 $srcdir/artifacts/PharoLauncher-linux-3.1.1-x64/pharo-launcher.png $pkgdir/usr/share/pixmaps/$pkgname.png
+ install -Dm644 $srcdir/icon-opaque-512x512.png $pkgdir/usr/share/pixmaps/pharo.png
install -Dm644 "$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
+ install -Dm644 "pharo.desktop" "$pkgdir/usr/share/applications/pharo.desktop"
# fix vm stuff
mkdir -p $pkgdir/etc/security/limits.d/
cp $srcdir/pharo.conf $pkgdir/etc/security/limits.d/pharo.conf
- $pkgdir/usr/share/pharo-vm/pharo --headless $pkgdir/usr/share/pharo-launcher/PharoLauncher.image st $srcdir/launcher-patch.st
+ $pkgdir/usr/share/pharo-vm/pharo-launcher --headless $pkgdir/usr/share/pharo-launcher/PharoLauncher.image st $srcdir/launcher-patch.st
}