summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorblubbblubb2019-04-30 15:20:20 +0200
committerblubbblubb2019-04-30 15:20:20 +0200
commit4e780bcfbfeac9b1769c412e69d4da0ba842242b (patch)
tree84dbf97d615786883161026fe062cbdceb9b6611
parent232204200b0a9614c2ba9fa0716210fd5524f988 (diff)
downloadaur-4e780bcfbfeac9b1769c412e69d4da0ba842242b.tar.gz
fixed Image.VERSION error
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--phatch.patch30
3 files changed, 31 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 14a6d057fb6c..27fe2260d1db 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = phatch
pkgdesc = A simple to use cross-platform GUI Photo Batch Processor.
pkgver = 0.2.7.1
- pkgrel = 10
+ pkgrel = 11
url = http://photobatch.stani.be
install = phatch.install
arch = i686
@@ -16,8 +16,8 @@ pkgbase = phatch
provides = phatch=0.2.7.1
source = https://launchpad.net/ubuntu/+archive/primary/+files/phatch_0.2.7.1.orig.tar.gz
source = phatch.patch
- md5sums = c0638bcc6510d340c03c40ddfb0a0c2f
- md5sums = 2716d5d4aa241a4d45fd9e1fec486fad
+ sha256sums = ba602095f6a78b53fe71825dd6b9786babf6e226dddcab6d72db012ff1e8d91d
+ sha256sums = 78bfc00ae82e7a5825949e5dfd5f9f1cdb966bb03fbe5be4ef871b5fd17b0256
pkgname = phatch
diff --git a/PKGBUILD b/PKGBUILD
index b7cf7c30f194..ebd88efdd6a0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=phatch
pkgver=0.2.7.1
pkgmajorv=0.2.7
-pkgrel=10
+pkgrel=11
pkgdesc="A simple to use cross-platform GUI Photo Batch Processor."
arch=('i686' 'x86_64')
url="http://photobatch.stani.be"
@@ -16,8 +16,8 @@ provides=(phatch="$pkgver")
install="$pkgname.install"
source=("https://launchpad.net/ubuntu/+archive/primary/+files/${pkgname}_${pkgver}.orig.tar.gz"
'phatch.patch')
-md5sums=('c0638bcc6510d340c03c40ddfb0a0c2f'
- '2716d5d4aa241a4d45fd9e1fec486fad')
+sha256sums=('ba602095f6a78b53fe71825dd6b9786babf6e226dddcab6d72db012ff1e8d91d'
+ '78bfc00ae82e7a5825949e5dfd5f9f1cdb966bb03fbe5be4ef871b5fd17b0256')
prepare() {
cd "$srcdir/$pkgname-$pkgmajorv"
diff --git a/phatch.patch b/phatch.patch
index c9545e6e44a7..fbae356f8b00 100644
--- a/phatch.patch
+++ b/phatch.patch
@@ -607,18 +607,20 @@ index ce1e668..8b978e8 100644
except ImportError:
sys.exit(PYWX_ERROR)
diff --git a/phatch/core/config.py b/phatch/core/config.py
-index 7f1d670..51a7fa9 100644
+index 7f1d670..2ea39ad 100644
--- a/phatch/core/config.py
+++ b/phatch/core/config.py
-@@ -214,7 +214,7 @@ def init_config_paths(config_paths=None):
+@@ -214,8 +214,8 @@ def init_config_paths(config_paths=None):
phatch_path = fix_python_path(config_paths.get('PHATCH_PYTHON_PATH', None))
#patches for pil <= 1.1.6 (ImportError=skip during build process)
try:
- import Image
+- if Image.VERSION < '1.1.7':
+ from PIL import Image
- if Image.VERSION < '1.1.7':
++ if Image.__version__ < '1.1.7':
fix_python_path(os.path.join(phatch_path, 'other', 'pil_1_1_6'))
except ImportError:
+ pass
diff --git a/phatch/core/models.py b/phatch/core/models.py
index 2404ec3..f331714 100644
--- a/phatch/core/models.py
@@ -672,7 +674,7 @@ index 6efa1b4..f2a8b3d 100644
pil_credits['name'] += ' %s' % Image.VERSION
if not (pil_credits in CREDITS['libraries']):
diff --git a/phatch/lib/imtools.py b/phatch/lib/imtools.py
-index ae22acc..0a21c5e 100644
+index ae22acc..4f8c6fe 100644
--- a/phatch/lib/imtools.py
+++ b/phatch/lib/imtools.py
@@ -20,10 +20,10 @@ from cStringIO import StringIO
@@ -690,6 +692,15 @@ index ae22acc..0a21c5e 100644
import system
+@@ -475,7 +475,7 @@ def has_transparency(image):
+ has_alpha(image)
+
+
+-if Image.VERSION == '1.1.7':
++if Image.__version__ == '1.1.7':
+
+ def split(image):
+ """Work around for bug in Pil 1.1.7
diff --git a/phatch/lib/metadata.py b/phatch/lib/metadata.py
index ec4b76d..c666fd1 100644
--- a/phatch/lib/metadata.py
@@ -740,7 +751,7 @@ index ec4b76d..c666fd1 100644
>>> list(InfoExtract.get_vars_by_info(['mode'])[0].values())
[['mode', 'orientation']]
diff --git a/phatch/lib/openImage.py b/phatch/lib/openImage.py
-index 2d2b07d..8e09232 100644
+index 2d2b07d..17e5f75 100644
--- a/phatch/lib/openImage.py
+++ b/phatch/lib/openImage.py
@@ -18,7 +18,7 @@
@@ -752,6 +763,15 @@ index 2d2b07d..8e09232 100644
import imtools
import system
+@@ -53,7 +53,7 @@ def open(uri):
+ except IOError, message:
+ ok = False
+ # interlaced png
+- if ok and not(Image.VERSION < '1.1.7' and
++ if ok and not(Image.__version__ < '1.1.7' and
+ image.format == 'PNG' and 'interlace' in image.info):
+ return image
+ # png, tiff (which pil can only handle partly)
diff --git a/phatch/lib/pyWx/dialogsInspector.py b/phatch/lib/pyWx/dialogsInspector.py
index 8ff3511..02fd820 100644
--- a/phatch/lib/pyWx/dialogsInspector.py