summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnish Bhatt2013-08-19 14:52:51 -0700
committerAnish Bhatt2013-08-19 14:52:51 -0700
commitcf58320614485e584aba9ccccacc47eb87008e46 (patch)
treef3ee5929c92095c030fc4c7df1393e9b49652db7
downloadaur-cf58320614485e584aba9ccccacc47eb87008e46.tar.gz
add phatch sources
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD23
-rw-r--r--phatch.install18
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..af74150b2097
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = phatch
+ pkgdesc = Phatch is a simple to use cross-platform GUI Photo Batch Processor.
+ pkgver = 0.2.7.1
+ pkgrel = 6
+ url = http://photobatch.stani.be
+ install = phatch.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = python2
+ depends = wxpython
+ depends = python-imaging
+ depends = mlocate
+ optdepends = python-nautilus
+ optdepends = pyexiv2
+ source = https://launchpad.net/ubuntu/+archive/primary/+files/phatch_0.2.7.1.orig.tar.gz
+ md5sums = c0638bcc6510d340c03c40ddfb0a0c2f
+
+pkgname = phatch
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..84dfb5ef7e99
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Original Contributor: Archie <xMickael@ifrance.com>
+# Maintainer : Anish Bhatt <anish[removethis][at]gatech[dot]edu>
+
+pkgname=phatch
+pkgver=0.2.7.1
+pkgmajorv=0.2.7
+pkgrel=6
+pkgdesc="Phatch is a simple to use cross-platform GUI Photo Batch Processor."
+depends=('python2' 'wxpython' 'python-imaging' 'mlocate')
+optdepends=('python-nautilus' 'pyexiv2')
+arch=('i686' 'x86_64')
+license=('GPL')
+
+source=("https://launchpad.net/ubuntu/+archive/primary/+files/${pkgname}_${pkgver}.orig.tar.gz" )
+
+url="http://photobatch.stani.be"
+md5sums=('c0638bcc6510d340c03c40ddfb0a0c2f' )
+install='phatch.install'
+
+package() {
+ pushd ${srcdir}/${pkgname}-${pkgmajorv}
+ python2 setup.py install --root=${pkgdir}
+}
diff --git a/phatch.install b/phatch.install
new file mode 100644
index 000000000000..6e4de7628863
--- /dev/null
+++ b/phatch.install
@@ -0,0 +1,18 @@
+post_install() {
+ echo "update desktop mime database..."
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+
+post_remove() {
+ echo "update desktop mime database..."
+ update-desktop-database -q
+}
+
+op=$1
+shift
+$op $*