summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordreieck2023-02-21 13:21:44 +0100
committerdreieck2023-02-21 13:21:44 +0100
commitae9ae3fec6fb16281aa1290da77bcfc31fef9226 (patch)
treeef7543e7963f005de411678e4011dc0b4b5a055e
parentf917c448d277fdc0db723c8eab3b31a279ae130d (diff)
downloadaur-ae9ae3fec6fb16281aa1290da77bcfc31fef9226.tar.gz
Sanitised `phc-intel.sh`, while this, did a version bump due to the changes carried out previously.
Changed tab to spaces in the `phc-intel.sleep*`-files.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD10
-rwxr-xr-xphc-intel.sh13
-rwxr-xr-xphc-intel.sleep.pm-utils6
-rwxr-xr-xphc-intel.sleep.systemd2
5 files changed, 25 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0ed9c34cba77..4ef4197b9069 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = phc-intel-scripts
pkgdesc = Helper and init scripts for phc-intel, a frequency driver for Intel CPUs with undervolting feature.
- pkgver = 0.2
- pkgrel = 6
+ pkgver = 0.3
+ pkgrel = 1
url = https://gitlab.com/linux-phc/phc-intel
arch = any
groups = linux-phc
@@ -16,9 +16,9 @@ pkgbase = phc-intel-scripts
source = phc-intel.systemd
source = phc-intel-scripts.install
sha256sums = ce08a5a4107be1d5723f1f169d515e67b6c77893f3994fc2d0d2ccf611307ed3
- sha256sums = 7450e00dbac86560dca37c494de40a9c79250958df0795b89668b494c18855ed
- sha256sums = 569b85988cb38380fec85c25688b76abc24a46601aa8f58eb24eaebf863eebef
- sha256sums = 2e17c90d7bfae8f5070e46388e95d443188eaa7beb5ffdd418a0da090f2e7557
+ sha256sums = b3144438cc796b96515508ebbbb22f854fcd36a3af31872da090af85f4f6d441
+ sha256sums = 3f965edca571e5a4d2dd60939b252e15062b440ce6eb87021dc3170682eff0d7
+ sha256sums = 0217a76958e2aba747c89bfd3bef16dcd8377770014896ab749faf16c05a2e53
sha256sums = 66be32665dd8e3c153ce512678d3af3cbf24f36829556590736e0c21baf82d28
sha256sums = a18474513c628877d117bd3b096f085b95e5ec4f3618bb6eb59a1db1dd67de1b
sha256sums = 2998dea86b1c69a2f0668afd025de154bf3b9b6d0803bf3e3f46eab26d2df13f
diff --git a/PKGBUILD b/PKGBUILD
index 1dc53aa96462..c49a8c6c2d3b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,8 +11,8 @@ groups=(
'linux-phc'
'phc-intel'
)
-pkgver=0.2
-pkgrel=6
+pkgver=0.3
+pkgrel=1
pkgdesc="Helper and init scripts for phc-intel, a frequency driver for Intel CPUs with undervolting feature."
url="https://gitlab.com/linux-phc/phc-intel"
arch=('any')
@@ -30,9 +30,9 @@ source=(
)
sha256sums=(
'ce08a5a4107be1d5723f1f169d515e67b6c77893f3994fc2d0d2ccf611307ed3' # phc-intel.conf.default
- '7450e00dbac86560dca37c494de40a9c79250958df0795b89668b494c18855ed' # phc-intel.sh
- '569b85988cb38380fec85c25688b76abc24a46601aa8f58eb24eaebf863eebef' # phc-intel.sleep.pm-utils
- '2e17c90d7bfae8f5070e46388e95d443188eaa7beb5ffdd418a0da090f2e7557' # phc-intel.sleep.systemd
+ 'b3144438cc796b96515508ebbbb22f854fcd36a3af31872da090af85f4f6d441' # phc-intel.sh
+ '3f965edca571e5a4d2dd60939b252e15062b440ce6eb87021dc3170682eff0d7' # phc-intel.sleep.pm-utils
+ '0217a76958e2aba747c89bfd3bef16dcd8377770014896ab749faf16c05a2e53' # phc-intel.sleep.systemd
'66be32665dd8e3c153ce512678d3af3cbf24f36829556590736e0c21baf82d28' # phc-intel.openrc
'a18474513c628877d117bd3b096f085b95e5ec4f3618bb6eb59a1db1dd67de1b' # phc-intel.sysvinit
'2998dea86b1c69a2f0668afd025de154bf3b9b6d0803bf3e3f46eab26d2df13f' # phc-intel.systemd
diff --git a/phc-intel.sh b/phc-intel.sh
index 7bc228130aba..01236845c348 100755
--- a/phc-intel.sh
+++ b/phc-intel.sh
@@ -33,7 +33,8 @@ check_kernel_cmdline() {
for i in $(< /proc/cmdline); do
if [ $i = nophc ]; then
errmsg "=> 'nophc' kernel option set, not setting PHC VIDs."
- errmsg " Use '$0 set' to override."
+ errmsg " Use '$0 force-set' to override."
+ exit 0
return 1
fi
done
@@ -78,11 +79,19 @@ case "$1" in
;;
set)
+ "$0" start
+ ;;
+
+ force-set)
check_conf_and_set "$@"
;;
+ reset)
+ "$0" stop
+ ;;
+
*)
- echo "usage: $0 {start|stop|status|set|reset}"
+ echo "usage: $0 {start|stop|status|set|force-set|reset}"
;;
esac
diff --git a/phc-intel.sleep.pm-utils b/phc-intel.sleep.pm-utils
index 342b81acf831..a8d4f4fd7cbd 100755
--- a/phc-intel.sleep.pm-utils
+++ b/phc-intel.sleep.pm-utils
@@ -1,7 +1,7 @@
#!/bin/bash
case $1 in
- resume|thaw)
- . /usr/bin/phc-intel set
- ;;
+ resume|thaw)
+ /usr/bin/phc-intel set
+ ;;
esac
diff --git a/phc-intel.sleep.systemd b/phc-intel.sleep.systemd
index c76ea6aafda0..231122753f67 100755
--- a/phc-intel.sleep.systemd
+++ b/phc-intel.sleep.systemd
@@ -1,5 +1,5 @@
#!/bin/bash
if [ "$1" = post ]; then
- . /usr/bin/phc-intel set
+ /usr/bin/phc-intel set
fi