summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarc-Olivier Barre2021-01-14 12:26:54 +0100
committerMarc-Olivier Barre2021-01-14 12:26:54 +0100
commit1f85351554b1f6a28da7dd7dd2ff79c3469419d1 (patch)
tree6da374095917c717b641dfe53444c4d4da542116
downloadaur-1f85351554b1f6a28da7dd7dd2ff79c3469419d1.tar.gz
Initial version of a package for 2.6.9
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD28
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1bfeea2e0943
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = phd2
+ pkgdesc = Open PHD Guiding - PHD2 astrophotography autoguiding tool
+ pkgver = 2.6.9
+ pkgrel = 1
+ url = http://openphdguiding.org/
+ arch = i686
+ arch = x86_64
+ license = BSD3
+ makedepends = git
+ makedepends = cmake
+ depends = wxgtk2
+ depends = v4l-utils
+ depends = zlib
+ depends = cfitsio
+ depends = opencv
+ depends = libnova
+ depends = libindi
+ source = https://github.com/OpenPHDGuiding/phd2/archive/v2.6.9.zip
+ sha256sums = 381cc2621c2ab697bcdeed90a85a0a7b487c2b5a08871c047e245568261eda71
+
+pkgname = phd2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eb5753e161dd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+pkgname=phd2
+pkgver=2.6.9
+pkgrel=1
+pkgdesc="Open PHD Guiding - PHD2 astrophotography autoguiding tool"
+url="http://openphdguiding.org/"
+arch=('i686' 'x86_64')
+license=('BSD3')
+depends=('wxgtk2' 'v4l-utils' 'zlib' 'cfitsio' 'opencv' 'libnova' 'libindi')
+makedepends=('git' 'cmake')
+source=("https://github.com/OpenPHDGuiding/phd2/archive/v${pkgver}.zip")
+sha256sums=('381cc2621c2ab697bcdeed90a85a0a7b487c2b5a08871c047e245568261eda71')
+
+prepare() {
+ mkdir build
+ cd build
+ cmake ../phd2-$pkgver
+}
+
+build() {
+ cd build
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="${pkgdir}" install
+}
+