summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryjun1232020-07-24 21:07:45 +0800
committeryjun1232020-07-24 21:07:45 +0800
commit71593c31981fbec69c01bbcefc9a3780d83beec6 (patch)
tree55b31dc389b385d1f62da44a10bb432199149ba4
parent55da95c2a82a4fdd34a95f631c23afd727afb1de (diff)
downloadaur-71593c31981fbec69c01bbcefc9a3780d83beec6.tar.gz
add .INSTALL
-rw-r--r--.INSTALL37
-rw-r--r--PKGBUILD3
2 files changed, 39 insertions, 1 deletions
diff --git a/.INSTALL b/.INSTALL
new file mode 100644
index 000000000000..55ebec5753ec
--- /dev/null
+++ b/.INSTALL
@@ -0,0 +1,37 @@
+post_install() {
+ ECHOLEN=$(echo -e|awk '{print length($0)}')
+ if [ ${ECHOLEN} = '0' ]
+ then
+ ECHO='echo -e'
+ else
+ ECHO='echo'
+ fi
+
+ $ECHO ""
+ $ECHO " \033[32m+------------------------------------------------------+\033[0m"
+ $ECHO " \033[32m| phddns start(启动)| stop(停止) |\033[0m"
+ $ECHO " \033[32m| status(状态 | restart(重启)|version(版本)|\033[0m"
+ $ECHO " \033[32m| version(版本) |\033[0m"
+ $ECHO " \033[32m+------------------------------------------------------+\033[0m"
+}
+
+post_upgrade() {
+ ECHOLEN=$(echo -e|awk '{print length($0)}')
+ if [ ${ECHOLEN} = '0' ]
+ then
+ ECHO='echo -e'
+ else
+ ECHO='echo'
+ fi
+
+ $ECHO ""
+ $ECHO " \033[32m+------------------------------------------------------+\033[0m"
+ $ECHO " \033[32m| phddns start(启动)| stop(停止) |\033[0m"
+ $ECHO " \033[32m| status(状态 | restart(重启)|version(版本)|\033[0m"
+ $ECHO " \033[32m| version(版本) |\033[0m"
+ $ECHO " \033[32m+------------------------------------------------------+\033[0m"
+}
+
+# vim : set sw=2 ts=2 et:
+
+
diff --git a/PKGBUILD b/PKGBUILD
index ec012332d8ef..be17ca364624 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,13 @@
pkgname=phddns-bin
_pkgname=${pkgname%-bin}
pkgver=3.0.4
-pkgrel=1
+pkgrel=2
pkgdesc="Peanut shell is a dynamic DNS software, any place, any time, any lines, all can through fixed domain access to the remote host services"
arch=("armv7h")
url="https://hsk.oray.com/download/"
license=('custom')
options=('!strip')
+install='.INSTALL'
source=('LICENSE::https://service.oray.com/question/1820.html')
source_armv7h=("http://download.oray.com/peanuthull/embed/${_pkgname}_${pkgver}_systemd.deb")