summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCeleste2022-05-16 18:06:34 +0800
committerCeleste2022-05-16 18:06:34 +0800
commit8cc03b24058535c54a21c502cbfc850d1b087c7b (patch)
tree096435a3df3224044ba7f94ca95c6251f92aac88
parent5445a49e02b418d3919abd0b0950034c5c2c2588 (diff)
downloadaur-8cc03b24058535c54a21c502cbfc850d1b087c7b.tar.gz
[Upgrade] 5.2.0
-rw-r--r--.INSTALL6
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD25
3 files changed, 25 insertions, 23 deletions
diff --git a/.INSTALL b/.INSTALL
index caf3c40631c5..a377af2cfec8 100644
--- a/.INSTALL
+++ b/.INSTALL
@@ -4,13 +4,14 @@ post_install() {
snbuf=$(wget 127.0.0.1:16062/ora_service/getsn -T 3 -q -O - 2>/dev/null)
SN=`echo -e $snbuf | grep -oE '"device_sn":"[^\"]+' | cut -d ":" -f 2 | sed 's/\"//g'`
+ pkgver=${1%-*}
echo -e "\033[1;31mSuccessful installation of Phddns Service.\033[0m"
sleep 2
if [ `systemctl is-active phtunnel.service` == 'active' ]; then
echo -e ""
echo -e " \033[32m+--------------------------------------------------+\033[0m"
- echo -e " \033[32m| Oray Phtunnel Linux 5.0.0 |\033[0m"
+ echo -e " \033[32m| Oray Phtunnel Linux $pkgver |\033[0m"
echo -e " \033[32m+--------------------------------------------------+\033[0m"
echo -e " \033[32m| SN: $SN Default password: admin |\033[0m"
echo -e " \033[32m+--------------------------------------------------+\033[0m"
@@ -25,13 +26,14 @@ post_upgrade() {
snbuf=$(wget 127.0.0.1:16062/ora_service/getsn -T 3 -q -O - 2>/dev/null)
SN=`echo -e $snbuf | grep -oE '"device_sn":"[^\"]+' | cut -d ":" -f 2 | sed 's/\"//g'`
+ pkgver=${1%-*}
echo -e "\033[1;31mSuccessful installation of Phddns Service.\033[0m"
sleep 2
if [ `systemctl is-active phtunnel.service` == 'active' ]; then
echo -e ""
echo -e " \033[32m+--------------------------------------------------+\033[0m"
- echo -e " \033[32m| Oray Phtunnel Linux 5.0.0 |\033[0m"
+ echo -e " \033[32m| Oray Phtunnel Linux $pkgver |\033[0m"
echo -e " \033[32m+--------------------------------------------------+\033[0m"
echo -e " \033[32m| SN: $SN Default password: admin |\033[0m"
echo -e " \033[32m+--------------------------------------------------+\033[0m"
diff --git a/.SRCINFO b/.SRCINFO
index 991320261ce4..9137fcb978d3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = phddns-bin
pkgdesc = Peanut shell is a dynamic DNS software, any place, any time, any lines, all can through fixed domain access to the remote host services
- pkgver = 5.0.0
- pkgrel = 2
+ pkgver = 5.2.0
+ pkgrel = 1
url = https://hsk.oray.com/download/
install = .INSTALL
arch = x86_64
@@ -15,12 +15,11 @@ pkgbase = phddns-bin
conflicts = phtunnel
source = LICENSE::https://service.oray.com/question/1820.html
sha256sums = SKIP
- source_x86_64 = http://dl-cdn.oray.com/hsk/linux/phddns-5.0.0-amd64.deb
- sha256sums_x86_64 = f27b86a13684212b9e852a6ac20256d9fadf7ca3a402d4f4c5d70530dffd1c1c
- source_i686 = http://dl-cdn.oray.com/hsk/linux/phddns-5.0.0-i386.deb
- sha256sums_i686 = 882aaca32b86d1beb3d0daf3f3bce35ff1eb7500729a3cec48ee3427fb2e8b7b
- source_aarch64 = https://dl-cdn.oray.com/hsk/linux/phtunnel_5_0_rapi_aarch64.deb
- sha256sums_aarch64 = 3e7dd863442a2c62fedc343c6b0b9fd4c24c7f987a2d3392209ced3a4aba0db8
+ source_x86_64 = https://down.oray.com/hsk/linux/phddns_5.2.0_amd64.deb
+ sha256sums_x86_64 = 59c66efd3d623836614200ac9ff325cd1b1ec230681a0611f514784294bb8cf7
+ source_i686 = https://down.oray.com/hsk/linux/phddns_5.2.0_i386.deb
+ sha256sums_i686 = e5c7c7e968bbda877f55e4d15581854ce32b014a14927c4a98bb98a4dc4b0a6e
+ source_aarch64 = https://dl-cdn.oray.com/hsk/linux/phddns_5.1.0_rapi_aarch64.deb
+ sha256sums_aarch64 = 945963a4696d4629b1bbfd9c5555408d3fe5dde46a4b8639f33aa0830bcb0e72
pkgname = phddns-bin
-
diff --git a/PKGBUILD b/PKGBUILD
index 19bdfcb018ac..14efb1bf1a64 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,11 @@
-# Maintainer: yjun <jerrysteve1104 at gmail dot com>
+# Maintainer: Celeste <yuan.zx at outlook dot com>
+# Contributor: yjun <jerrysteve1104 at gmail dot com>
pkgname=phddns-bin
_pkgname=${pkgname%-bin}
-pkgver=5.0.0
-_pkgver=5.0
-pkgrel=2
+pkgver=5.2.0
+_pkgver_aarch=5.1.0
+pkgrel=1
pkgdesc="Peanut shell is a dynamic DNS software, any place, any time, any lines, all can through fixed domain access to the remote host services"
arch=("x86_64" "i686" "aarch64")
depends=('wget')
@@ -14,18 +15,18 @@ url="https://hsk.oray.com/download/"
license=('custom')
install='.INSTALL'
source=('LICENSE::https://service.oray.com/question/1820.html')
-source_x86_64=("http://dl-cdn.oray.com/hsk/linux/${_pkgname}-${pkgver}-amd64.deb")
-source_i686=("http://dl-cdn.oray.com/hsk/linux/${_pkgname}-${pkgver}-i386.deb")
-source_aarch64=("https://dl-cdn.oray.com/hsk/linux/phtunnel_${_pkgver//./_}_rapi_aarch64.deb")
+source_x86_64=("https://down.oray.com/hsk/linux/${_pkgname}_${pkgver}_amd64.deb")
+source_i686=("https://down.oray.com/hsk/linux/${_pkgname}_${pkgver}_i386.deb")
+source_aarch64=("https://dl-cdn.oray.com/hsk/linux/${_pkgname}_${_pkgver_aarch}_rapi_aarch64.deb")
sha256sums=('SKIP')
-sha256sums_x86_64=('f27b86a13684212b9e852a6ac20256d9fadf7ca3a402d4f4c5d70530dffd1c1c')
-sha256sums_i686=('882aaca32b86d1beb3d0daf3f3bce35ff1eb7500729a3cec48ee3427fb2e8b7b')
-sha256sums_aarch64=('3e7dd863442a2c62fedc343c6b0b9fd4c24c7f987a2d3392209ced3a4aba0db8')
+sha256sums_x86_64=('59c66efd3d623836614200ac9ff325cd1b1ec230681a0611f514784294bb8cf7')
+sha256sums_i686=('e5c7c7e968bbda877f55e4d15581854ce32b014a14927c4a98bb98a4dc4b0a6e')
+sha256sums_aarch64=('945963a4696d4629b1bbfd9c5555408d3fe5dde46a4b8639f33aa0830bcb0e72')
package() {
install -dm755 ${srcdir}/${pkgname}
- tar -xf data.tar.xz -C ${srcdir}/${pkgname}
+ tar -xf data.tar.gz -C ${srcdir}/${pkgname}
# binary
install -Dm755 -t ${pkgdir}/usr/bin/ ${srcdir}/${pkgname}/usr/bin/phtunnel
@@ -44,6 +45,6 @@ package() {
# license
install -Dm644 -t ${pkgdir}/usr/share/licenses/${pkgname}/ ${srcdir}/LICENSE
-}
+}
# vim: ts=2 sw=2 et: