summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryjun1232020-09-11 23:43:47 +0800
committeryjun1232020-09-11 23:43:47 +0800
commitb6729be665963adfa4e876011d703484b9b95606 (patch)
treecc048484c5e6e5f212514823d11fc723306dd481
parentd777ebd6a484a95098d9c3eb085a81af63534cb2 (diff)
downloadaur-b6729be665963adfa4e876011d703484b9b95606.tar.gz
added aarch64 architecture supported
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD21
2 files changed, 20 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1050a44c7a8a..63db382faeec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,16 +6,21 @@ pkgbase = phddns-bin
install = .INSTALL
arch = x86_64
arch = i686
+ arch = aarch64
license = custom
depends = wget
provides = phddns
+ provides = phtunnel
conflicts = phddns
+ conflicts = phtunnel
source = LICENSE::https://service.oray.com/question/1820.html
sha256sums = SKIP
source_x86_64 = http://dl-cdn.oray.com/hsk/linux/phddns-5.0.0-amd64.deb
sha256sums_x86_64 = f27b86a13684212b9e852a6ac20256d9fadf7ca3a402d4f4c5d70530dffd1c1c
source_i686 = http://dl-cdn.oray.com/hsk/linux/phddns-5.0.0-i386.deb
sha256sums_i686 = 882aaca32b86d1beb3d0daf3f3bce35ff1eb7500729a3cec48ee3427fb2e8b7b
+ source_aarch64 = https://dl-cdn.oray.com/hsk/linux/phtunnel_5_0_rapi_aarch64.deb
+ sha256sums_aarch64 = 3e7dd863442a2c62fedc343c6b0b9fd4c24c7f987a2d3392209ced3a4aba0db8
pkgname = phddns-bin
diff --git a/PKGBUILD b/PKGBUILD
index 1a03f7d4f846..4a4c722e155d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,22 +3,25 @@
pkgname=phddns-bin
_pkgname=${pkgname%-bin}
pkgver=5.0.0
+_pkgver=5.0
pkgrel=1
pkgdesc="Peanut shell is a dynamic DNS software, any place, any time, any lines, all can through fixed domain access to the remote host services"
-arch=("x86_64" "i686")
+arch=("x86_64" "i686" "aarch64")
depends=('wget')
-provides=("${_pkgname}")
-conflicts=("${_pkgname}")
+provides=("${_pkgname}" "phtunnel")
+conflicts=("${_pkgname}" "phtunnel")
url="https://hsk.oray.com/download/"
license=('custom')
install='.INSTALL'
source=('LICENSE::https://service.oray.com/question/1820.html')
source_x86_64=("http://dl-cdn.oray.com/hsk/linux/${_pkgname}-${pkgver}-amd64.deb")
source_i686=("http://dl-cdn.oray.com/hsk/linux/${_pkgname}-${pkgver}-i386.deb")
+source_aarch64=("https://dl-cdn.oray.com/hsk/linux/phtunnel_${_pkgver//./_}_rapi_aarch64.deb")
sha256sums=('SKIP')
sha256sums_x86_64=('f27b86a13684212b9e852a6ac20256d9fadf7ca3a402d4f4c5d70530dffd1c1c')
sha256sums_i686=('882aaca32b86d1beb3d0daf3f3bce35ff1eb7500729a3cec48ee3427fb2e8b7b')
+sha256sums_aarch64=('3e7dd863442a2c62fedc343c6b0b9fd4c24c7f987a2d3392209ced3a4aba0db8')
package() {
install -dm755 ${srcdir}/${pkgname}
@@ -26,10 +29,16 @@ package() {
# binary
install -Dm755 -t ${pkgdir}/usr/bin/ ${srcdir}/${pkgname}/usr/bin/phtunnel
-
+ if [ $CARCH == "aarch64" ];then
+ install -Dm755 -t ${pkgdir}/usr/bin/ ${srcdir}/${pkgname}/usr/bin/phddns
+ fi
+
# systemd service
- install -Dm644 -t ${pkgdir}/usr/lib/systemd/system/ ${srcdir}/${pkgname}/tmp/pht_script/phtunnel.service
-
+ if [ $CARCH == "aarch64" ];then
+ install -Dm644 -t ${pkgdir}/usr/lib/systemd/system/ ${srcdir}/${pkgname}/lib/systemd/system/phtunnel.service
+ else
+ install -Dm644 -t ${pkgdir}/usr/lib/systemd/system/ ${srcdir}/${pkgname}/tmp/pht_script/phtunnel.service
+ fi
# license
install -Dm644 -t ${pkgdir}/usr/share/licenses/${pkgname}/ ${srcdir}/LICENSE
}