summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin A. Shelton2015-06-25 19:54:47 -0600
committerBenjamin A. Shelton2015-06-25 19:54:47 -0600
commit10c2c498a51527c82b216188c31682dd77293dd5 (patch)
treece009e92acc2bce2bffee5b70cfbefc31bbe62d5
downloadaur-10c2c498a51527c82b216188c31682dd77293dd5.tar.gz
Initial commit.
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD39
-rw-r--r--phing.install45
3 files changed, 101 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1917ad962eb4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = phing
+ pkgdesc = PHP project build system based on Apache Ant.
+ pkgver = 2.11.0
+ pkgrel = 1
+ url = http://www.phing.info/
+ install = phing.install
+ arch = any
+ license = LGPL
+ makedepends = php-pear
+ depends = php
+ source = http://pear.phing.info/get/phing-2.11.0.tgz
+ source = phing.install
+ sha256sums = f7fbd82d1c47e7de753df34e675cf705ef24247c44c94b7ea6354767c028d5ba
+ sha256sums = d6b73432293ff2dfe9ae4866d77b68c05721b0ffd3bd332bc58678f624c03f4b
+
+pkgname = phing
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6a282d2102cc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Benjamin A. Shelton <zancarius@gmail.com>
+# Source: https://github.com/zancarius/archlinux-pkgbuilds
+
+pkgname=phing
+pkgver=2.11.0
+pkgrel=1
+pkgdesc="PHP project build system based on Apache Ant."
+arch=(any)
+url="http://www.phing.info/"
+license=(LGPL)
+depends=(php)
+makedepends=(php-pear)
+install="${pkgname}.install"
+source=(
+ "http://pear.phing.info/get/${pkgname}-${pkgver}.tgz"
+ phing.install
+)
+sha256sums=(
+ f7fbd82d1c47e7de753df34e675cf705ef24247c44c94b7ea6354767c028d5ba # phing tarball
+ d6b73432293ff2dfe9ae4866d77b68c05721b0ffd3bd332bc58678f624c03f4b # phing.install
+)
+
+package() {
+
+ # Work around for the inability to use channel-discover as non-root
+ # without tweaking or adding a ~/.pearrc. This is a kluge, yikes!
+ cat "${srcdir}/package.xml" | sed -e "s/^ <channel>pear.phing.info<\/channel>/ <channel>pear.php.net<\/channel>/" > "${srcdir}/package.xml.new"
+ mv "${srcdir}/package.xml.new" "${srcdir}/package.xml"
+
+ cd "${srcdir}"
+ tar czvf "${pkgname}-rebuild.tgz" package.xml ${pkgname}-${pkgver}
+
+ pear install -P"${pkgdir}" -O -n "${srcdir}/${pkgname}-rebuild.tgz"
+
+ rm -r "${pkgdir}"/usr/share/pear/{.channels,.depdb*,.filemap,.lock}
+
+ install -Dm0644 "${srcdir}/${pkgname}-${pkgver}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+}
diff --git a/phing.install b/phing.install
new file mode 100644
index 000000000000..d83aa442f9dc
--- /dev/null
+++ b/phing.install
@@ -0,0 +1,45 @@
+post_install(){
+
+cat << EOF
+
+Phing performs some configuration auto-discovery and detection for the
+presence of Composer-specific files and may cause PHP to generate messages
+if open_basedir is configured. Although annoying, these messages will not
+affect Phing's behavior. The solution, though certainly not ideal, is to
+add "/usr/share" to open_basedir as Phing attempts to probe one level up
+from the PEAR root (/usr/share/pear). Optionally, using separate php.ini
+configurations for the PHP CLI and web server modules may be more
+appropriate if you're a developer or perform a great deal of work using
+PHP on the command line.
+
+Phing in stand-alone format works well, but the recommended method is to
+install it on a per-project basis using Composer (http://getcomposer.org).
+I would highly recommend installing Phing per-project rather than
+system-wide.
+
+EOF
+
+}
+
+post_upgrade(){
+
+cat << EOF
+
+Phing performs some configuration auto-discovery and detection for the
+presence of Composer-specific files and may cause PHP to generate messages
+if open_basedir is configured. Although annoying, these messages will not
+affect Phing's behavior. The solution, though certainly not ideal, is to
+add "/usr/share" to open_basedir as Phing attempts to probe one level up
+from the PEAR root (/usr/share/pear). Optionally, using separate php.ini
+configurations for the PHP CLI and web server modules may be more
+appropriate if you're a developer or perform a great deal of work using
+PHP on the command line.
+
+Phing in stand-alone format works well, but the recommended method is to
+install it on a per-project basis using Composer (http://getcomposer.org).
+I would highly recommend installing Phing per-project rather than
+system-wide.
+
+EOF
+
+}