summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin A. Shelton2015-08-18 14:14:28 -0600
committerBenjamin A. Shelton2015-08-18 14:14:28 -0600
commit633d9ecd2b8ff6380c05da22de7e371ab804c583 (patch)
tree6399eea1f9c5a90ec5e588df3323a16bb1fa93ea
parent10c2c498a51527c82b216188c31682dd77293dd5 (diff)
downloadaur-633d9ecd2b8ff6380c05da22de7e371ab804c583.tar.gz
Dumped PEAR version of Phing. We're now using the PHAR version provided by phing.info.
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD29
-rw-r--r--phar.ini1
-rw-r--r--phing.install44
4 files changed, 32 insertions, 53 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1917ad962eb4..3d86dcffdb1a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
pkgbase = phing
pkgdesc = PHP project build system based on Apache Ant.
pkgver = 2.11.0
- pkgrel = 1
+ pkgrel = 2
url = http://www.phing.info/
install = phing.install
arch = any
license = LGPL
- makedepends = php-pear
depends = php
- source = http://pear.phing.info/get/phing-2.11.0.tgz
+ source = http://www.phing.info/get/phing-2.11.0.phar
source = phing.install
- sha256sums = f7fbd82d1c47e7de753df34e675cf705ef24247c44c94b7ea6354767c028d5ba
- sha256sums = d6b73432293ff2dfe9ae4866d77b68c05721b0ffd3bd332bc58678f624c03f4b
+ source = phar.ini
+ sha256sums = 355ff478baa0dc67d80fb2b0bcc6f231ff25e0dfa600f08c4b107f689d551dd8
+ sha256sums = 9c9926fcea67efad95adceeaa973cd86f99681a74d22b93d2c5fa506679c65cd
+ sha256sums = b189ab599a2760b7627820dffece09a4323c9ed2e042c2517e97801f602b318e
pkgname = phing
diff --git a/PKGBUILD b/PKGBUILD
index 6a282d2102cc..5e0a71d23947 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,37 +3,26 @@
pkgname=phing
pkgver=2.11.0
-pkgrel=1
+pkgrel=2
pkgdesc="PHP project build system based on Apache Ant."
arch=(any)
url="http://www.phing.info/"
license=(LGPL)
depends=(php)
-makedepends=(php-pear)
install="${pkgname}.install"
source=(
- "http://pear.phing.info/get/${pkgname}-${pkgver}.tgz"
+ "http://www.phing.info/get/phing-${pkgver}.phar"
phing.install
+ phar.ini
)
sha256sums=(
- f7fbd82d1c47e7de753df34e675cf705ef24247c44c94b7ea6354767c028d5ba # phing tarball
- d6b73432293ff2dfe9ae4866d77b68c05721b0ffd3bd332bc58678f624c03f4b # phing.install
+ 355ff478baa0dc67d80fb2b0bcc6f231ff25e0dfa600f08c4b107f689d551dd8 # phing PHAR
+ 9c9926fcea67efad95adceeaa973cd86f99681a74d22b93d2c5fa506679c65cd # phing.install
+ b189ab599a2760b7627820dffece09a4323c9ed2e042c2517e97801f602b318e # phar.ini
)
package() {
-
- # Work around for the inability to use channel-discover as non-root
- # without tweaking or adding a ~/.pearrc. This is a kluge, yikes!
- cat "${srcdir}/package.xml" | sed -e "s/^ <channel>pear.phing.info<\/channel>/ <channel>pear.php.net<\/channel>/" > "${srcdir}/package.xml.new"
- mv "${srcdir}/package.xml.new" "${srcdir}/package.xml"
-
- cd "${srcdir}"
- tar czvf "${pkgname}-rebuild.tgz" package.xml ${pkgname}-${pkgver}
-
- pear install -P"${pkgdir}" -O -n "${srcdir}/${pkgname}-rebuild.tgz"
-
- rm -r "${pkgdir}"/usr/share/pear/{.channels,.depdb*,.filemap,.lock}
-
- install -Dm0644 "${srcdir}/${pkgname}-${pkgver}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
-
+ install -Dm0644 "${srcdir}/phar.ini" "${pkgdir}/etc/php/conf.d/phar.ini"
+ install -Dm0755 "${srcdir}/${pkgname}-${pkgver}.phar" "${pkgdir}/usr/bin/${pkgname}-${pkgver}.phar"
+ ln --relative -s "${pkgdir}/usr/bin/${pkgname}-${pkgver}.phar" "${pkgdir}/usr/bin/phing"
}
diff --git a/phar.ini b/phar.ini
new file mode 100644
index 000000000000..32391d6ab8a8
--- /dev/null
+++ b/phar.ini
@@ -0,0 +1 @@
+extension=phar.so \ No newline at end of file
diff --git a/phing.install b/phing.install
index d83aa442f9dc..7570be25b833 100644
--- a/phing.install
+++ b/phing.install
@@ -2,20 +2,14 @@ post_install(){
cat << EOF
-Phing performs some configuration auto-discovery and detection for the
-presence of Composer-specific files and may cause PHP to generate messages
-if open_basedir is configured. Although annoying, these messages will not
-affect Phing's behavior. The solution, though certainly not ideal, is to
-add "/usr/share" to open_basedir as Phing attempts to probe one level up
-from the PEAR root (/usr/share/pear). Optionally, using separate php.ini
-configurations for the PHP CLI and web server modules may be more
-appropriate if you're a developer or perform a great deal of work using
-PHP on the command line.
-
-Phing in stand-alone format works well, but the recommended method is to
-install it on a per-project basis using Composer (http://getcomposer.org).
-I would highly recommend installing Phing per-project rather than
-system-wide.
+=========
+As of PKGREL phing-2.11.0-2, this PKGBUILD downloads the PHAR build of
+phing.
+
+Stand-alone Phing works well, but the recommended means of using it is
+to install the package on a per-project basis via Composer
+(http://getcomposer.org).
+=========
EOF
@@ -25,20 +19,14 @@ post_upgrade(){
cat << EOF
-Phing performs some configuration auto-discovery and detection for the
-presence of Composer-specific files and may cause PHP to generate messages
-if open_basedir is configured. Although annoying, these messages will not
-affect Phing's behavior. The solution, though certainly not ideal, is to
-add "/usr/share" to open_basedir as Phing attempts to probe one level up
-from the PEAR root (/usr/share/pear). Optionally, using separate php.ini
-configurations for the PHP CLI and web server modules may be more
-appropriate if you're a developer or perform a great deal of work using
-PHP on the command line.
-
-Phing in stand-alone format works well, but the recommended method is to
-install it on a per-project basis using Composer (http://getcomposer.org).
-I would highly recommend installing Phing per-project rather than
-system-wide.
+=========
+As of PKGREL phing-2.11.0-2, this PKGBUILD downloads the PHAR build of
+phing.
+
+Stand-alone Phing works well, but the recommended means of using it is
+to install the package on a per-project basis via Composer
+(http://getcomposer.org).
+=========
EOF