summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUjhhgtg2023-07-30 17:00:51 +0800
committerUjhhgtg2023-07-30 17:12:48 +0800
commit670d1232339efe3aebdafd03ec920f822a79d82f (patch)
tree1187ab4e1161e2888666959fc0ea2b47ddf0cd48
parent2394a4f6f114bfde9cf5e9484fb40768a887b231 (diff)
downloadaur-670d1232339efe3aebdafd03ec920f822a79d82f.tar.gz
resize icon
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD34
-rw-r--r--phira.desktop10
-rw-r--r--phira.pngbin0 -> 382691 bytes
4 files changed, 42 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4f10e1f502fa..69f74ecc26ae 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = phira-bin
- pkgdesc = Phira is a clone of the music game Phigros that supports custom beatmaps, multiplayer etc.
+ pkgdesc = A clone of the music game Phigros that supports custom beatmaps, multiplayer etc.
pkgver = 0.4.0
pkgrel = 1
url = https://github.com/TeamFlos/phira
@@ -11,7 +11,11 @@ pkgbase = phira-bin
depends = bubblewrap
source = phira-v0.4.0.zip::https://github.com/TeamFlos/phira/releases/download/v0.4.0/Phira-linux-v0.4.0.zip
source = run.sh
+ source = phira.desktop
+ source = phira.png
b2sums = f70c1a067784ce7c74287a3621d5885fbcfa5edc26b60efd2985b40fc9674ef88259eea64a16e4fd090e7552cf48ef13f6ae46f37ad34b096af3836ade174c5b
b2sums = 7fc927449a92b07235c54fe05491c8cefd967649720f5ef2260dd58b3ae50893d72dd5c152f740b746969dd3991d2db7139b7e40e42077783664e0b02dc3bcbd
+ b2sums = e370a20c1c049f99d80852c25e396e28e7595e040fd2f565ccb05e4a8f56e5ec60f3b2be6a3dee5094768418a86ebd7bcfcf5870ae40094bde11c744c4df2c32
+ b2sums = f88a9b0a83856cfe861f3b69673757464c234c9244db1619ec4fcff8d9d05c7482b5555af7f593ab16267556f8eef138699e4abe548d72ed35172e545819dc2d
pkgname = phira-bin
diff --git a/PKGBUILD b/PKGBUILD
index fe7c31a1d30d..be658b1ae98d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=phira-bin
pkgver=0.4.0
pkgrel=1
-pkgdesc="Phira is a clone of the music game Phigros that supports custom beatmaps, multiplayer etc."
+pkgdesc="A clone of the music game Phigros that supports custom beatmaps, multiplayer etc."
arch=('x86_64')
url="https://github.com/TeamFlos/phira"
license=('GPL3')
@@ -21,12 +21,32 @@ makedepends=(
'cargo'
'git'
)
-source=("${pkgname%-bin}-v$pkgver.zip::https://github.com/TeamFlos/${pkgname%-bin}/releases/download/v$pkgver/Phira-linux-v$pkgver.zip" "run.sh")
-b2sums=('f70c1a067784ce7c74287a3621d5885fbcfa5edc26b60efd2985b40fc9674ef88259eea64a16e4fd090e7552cf48ef13f6ae46f37ad34b096af3836ade174c5b' '7fc927449a92b07235c54fe05491c8cefd967649720f5ef2260dd58b3ae50893d72dd5c152f740b746969dd3991d2db7139b7e40e42077783664e0b02dc3bcbd')
+source=(
+ "${pkgname%-bin}-v$pkgver.zip::https://github.com/TeamFlos/${pkgname%-bin}/releases/download/v$pkgver/Phira-linux-v$pkgver.zip"
+ "run.sh"
+ "${pkgname%-bin}.desktop"
+ "${pkgname%-bin}.png"
+)
+b2sums=(
+ 'f70c1a067784ce7c74287a3621d5885fbcfa5edc26b60efd2985b40fc9674ef88259eea64a16e4fd090e7552cf48ef13f6ae46f37ad34b096af3836ade174c5b'
+ '7fc927449a92b07235c54fe05491c8cefd967649720f5ef2260dd58b3ae50893d72dd5c152f740b746969dd3991d2db7139b7e40e42077783664e0b02dc3bcbd'
+ 'e370a20c1c049f99d80852c25e396e28e7595e040fd2f565ccb05e4a8f56e5ec60f3b2be6a3dee5094768418a86ebd7bcfcf5870ae40094bde11c744c4df2c32'
+ 'f88a9b0a83856cfe861f3b69673757464c234c9244db1619ec4fcff8d9d05c7482b5555af7f593ab16267556f8eef138699e4abe548d72ed35172e545819dc2d'
+)
package() {
- install -Dm755 "${pkgname%-bin}-main" "$pkgdir/usr/share/${pkgname%-bin}/${pkgname%-bin}-main"
- install -Dm755 "run.sh" "$pkgdir/usr/bin/phira"
- cp -r "assets" "$pkgdir/usr/share/${pkgname%-bin}/"
- install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/${pkgname%-bin}/LICENSE"
+ # game
+ install -Dm755 "${pkgname%-bin}-main" "$pkgdir/usr/share/${pkgname%-bin}/${pkgname%-bin}-main"
+ install -Dm755 "run.sh" "$pkgdir/usr/bin/phira"
+ cp -r "assets" "$pkgdir/usr/share/${pkgname%-bin}/"
+
+ # license
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/${pkgname%-bin}/LICENSE"
+
+ # desktop entry
+ install -Dm644 "${pkgname%-bin}.desktop" "$pkgdir/usr/share/applications/${pkgname%-bin}.desktop"
+
+ # icon
+ mkdir -p "${pkgdir}/usr/share/icons/hicolor/512x512/apps/"
+ install -Dm644 "${pkgname%-bin}.png" "${pkgdir}/usr/share/icons/hicolor/512x512/apps/${pkgname%-bin}.png"
}
diff --git a/phira.desktop b/phira.desktop
new file mode 100644
index 000000000000..7a44bbfa1e55
--- /dev/null
+++ b/phira.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=Phira
+GenericName=Music Game
+Version=0.4.0
+Exec=/usr/bin/phira
+Type=Application
+Terminal=false
+Icon=/usr/share/icons/hicolor/512x512/apps/phira.png
+Comment=A clone of the music game Phigros that supports custom beatmaps, multiplayer etc.
+Categories=Gaming;Music;Rust;
diff --git a/phira.png b/phira.png
new file mode 100644
index 000000000000..6cbf641d5ae2
--- /dev/null
+++ b/phira.png
Binary files differ