summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Goto2020-06-16 19:20:59 +0200
committerPhilip Goto2020-06-16 19:20:59 +0200
commit3ffb2c8b65e79ffed08eaca52a14db98e3b0f581 (patch)
tree66d50a79782d017c77138680c3d558c8f73d5a45
parentc87cab445bfacb6b24fc1940cd81062b0ae998c6 (diff)
downloadaur-3ffb2c8b65e79ffed08eaca52a14db98e3b0f581.tar.gz
Add mutter as depends and enable tests
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d86cac604821..9d66023e3059 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,19 @@
pkgbase = phoc
pkgdesc = Wlroots based Phone compositor
pkgver = 0.1.8
- pkgrel = 1
+ pkgrel = 2
url = https://source.puri.sm/Librem5/phoc
arch = i686
arch = x86_64
arch = armv7h
arch = aarch64
license = GPL3
+ checkdepends = xorg-server-xvfb
makedepends = ctags
makedepends = libhandy
makedepends = meson
makedepends = vala
- depends = gnome-desktop
+ depends = mutter
depends = wlroots
source = https://source.puri.sm/Librem5/phoc/-/archive/v0.1.8/phoc-v0.1.8.tar.gz
sha256sums = 56fff3a5d7ed1a3932826d3c767af835c42dc044245a6b9dc20890343d7fd090
diff --git a/PKGBUILD b/PKGBUILD
index f3e9d968fd40..545e299b55b3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,28 +2,29 @@
pkgname=phoc
pkgver=0.1.8
-pkgrel=1
+pkgrel=2
pkgdesc="Wlroots based Phone compositor"
url="https://source.puri.sm/Librem5/phoc"
license=("GPL3")
arch=(i686 x86_64 armv7h aarch64)
-depends=(gnome-desktop
+depends=(mutter
wlroots)
makedepends=(ctags
libhandy
meson
vala)
+checkdepends=(xorg-server-xvfb)
source=("https://source.puri.sm/Librem5/phoc/-/archive/v${pkgver}/phoc-v${pkgver}.tar.gz")
sha256sums=('56fff3a5d7ed1a3932826d3c767af835c42dc044245a6b9dc20890343d7fd090')
build() {
rm -rf build
- arch-meson phoc-v${pkgver} build -Dembed-wlroots=disabled -Dtests=false
+ arch-meson phoc-v${pkgver} build -Dembed-wlroots=disabled
ninja -C build
}
check() {
- ninja -C build test
+ xvfb-run ninja -C build test
}
package() {