summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Goto2020-10-30 16:19:34 +0100
committerPhilip Goto2020-10-30 16:19:34 +0100
commit4c8a2c48a7acf6bb9b28d1f994363eedc2a37f13 (patch)
tree93ac7c612e7947537ceebd177a11da811cb00f0f
parenta28355b8a98fd147d3f021d2ff0afa0f7318207b (diff)
downloadaur-4c8a2c48a7acf6bb9b28d1f994363eedc2a37f13.tar.gz
Update to 0.4.4
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
2 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6f9997a1a35c..765662a569ed 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = phoc
pkgdesc = Wlroots based Phone compositor
- pkgver = 0.4.3
+ pkgver = 0.4.4
pkgrel = 1
url = https://source.puri.sm/Librem5/phoc
arch = i686
@@ -15,8 +15,8 @@ pkgbase = phoc
makedepends = vala
depends = mutter
depends = wlroots
- source = https://source.puri.sm/Librem5/phoc/-/archive/v0.4.3/phoc-v0.4.3.tar.gz
- sha256sums = 30d496ee348c619bdf11c62a93ea599a5e000a77788e124b897c6731f1ae7c92
+ source = https://source.puri.sm/Librem5/phoc/-/archive/v0.4.4/phoc-v0.4.4.tar.gz
+ sha256sums = 49e418ebe0389d325a53306e538947d71f9fdce5bdd0ba3675c05e6b0577ea64
pkgname = phoc
diff --git a/PKGBUILD b/PKGBUILD
index 8908fc02722d..f7c14a644a74 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Philip Goto <philip.goto@gmail.com>
pkgname=phoc
-pkgver=0.4.3
+pkgver=0.4.4
pkgrel=1
pkgdesc="Wlroots based Phone compositor"
url="https://source.puri.sm/Librem5/phoc"
@@ -15,18 +15,19 @@ makedepends=(ctags
vala)
checkdepends=(xorg-server-xvfb)
source=("https://source.puri.sm/Librem5/phoc/-/archive/v${pkgver}/phoc-v${pkgver}.tar.gz")
-sha256sums=('30d496ee348c619bdf11c62a93ea599a5e000a77788e124b897c6731f1ae7c92')
+sha256sums=('49e418ebe0389d325a53306e538947d71f9fdce5bdd0ba3675c05e6b0577ea64')
build() {
- rm -rf build
arch-meson phoc-v${pkgver} build -Dembed-wlroots=disabled
- ninja -C build
+ meson compile -C build
}
check() {
- xvfb-run ninja -C build test
+ dbus-run-session xvfb-run \
+ -s '-screen 0 1920x1080x24 -nolisten local' \
+ meson test -C build --print-errorlogs
}
package() {
- DESTDIR="${pkgdir}" ninja -C build install
+ DESTDIR="${pkgdir}" meson install -C build
}