summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Booker2023-02-26 15:26:11 +1300
committerThomas Booker2023-02-26 15:26:11 +1300
commit37ee16b7ba9eec683b6acfd788e4368ccd7af3d9 (patch)
tree43c9a17151188798bda8dbd7af3e74977f455f13
parente5d264f9428a85eec6ce4d45617c28c1d19c4dc7 (diff)
downloadaur-37ee16b7ba9eec683b6acfd788e4368ccd7af3d9.tar.gz
Update to 24 and add checks
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD18
2 files changed, 14 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 02479e1b1528..f990143bd1b7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = phoc-embedded-wlroots
pkgdesc = A pure Wayland shell prototype for GNOME on mobile devices (wlroots embedded)
- pkgver = 0.21.0
+ pkgver = 0.24.0
pkgrel = 1
url = https://gitlab.gnome.org/World/Phosh/phoc
arch = x86_64
@@ -12,6 +12,7 @@ pkgbase = phoc-embedded-wlroots
makedepends = vulkan-headers
makedepends = wayland-protocols
makedepends = xorg-xwayland
+ makedepends = xorg-server-xvfb
depends = gobject-introspection
depends = gnome-desktop
depends = libinput
@@ -25,7 +26,7 @@ pkgbase = phoc-embedded-wlroots
provides = wlroots
conflicts = phoc
conflicts = wlroots
- source = git+https://gitlab.gnome.org/World/Phosh/phoc.git#tag=1a58a2363b686241647138a8822beac4f761f3fb
+ source = git+https://gitlab.gnome.org/World/Phosh/phoc.git#tag=8af5ef8f
sha256sums = SKIP
pkgname = phoc-embedded-wlroots
diff --git a/PKGBUILD b/PKGBUILD
index f0a2617b1635..bec10067b65c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Philip Goto <philip.goto@gmail.com>
pkgname=phoc-embedded-wlroots
-pkgver=0.21.0
+pkgver=0.24.0
pkgrel=1
pkgdesc='A pure Wayland shell prototype for GNOME on mobile devices (wlroots embedded)'
arch=(x86_64 aarch64 armv7h)
@@ -25,10 +25,11 @@ makedepends=(
vulkan-headers
wayland-protocols
xorg-xwayland
+ xorg-server-xvfb
)
provides=(phoc wlroots)
conflicts=(phoc wlroots)
-_tag=1a58a2363b686241647138a8822beac4f761f3fb
+_tag=8af5ef8f
source=("git+${url}.git#tag=${_tag}")
sha256sums=('SKIP')
@@ -40,15 +41,18 @@ pkgver() {
prepare() {
cd phoc
- git submodule init
- git submodule update
+ git submodule update --init
}
build() {
- arch-meson phoc _build -Dembed-wlroots=enabled -Dtests=false
- meson compile -C _build
+ arch-meson phoc build -Dembed-wlroots=enabled --default-library=static -Dtests=true
+ ninja -C build
+}
+
+check() {
+ xvfb-run ninja -C build test
}
package() {
- DESTDIR="${pkgdir}" meson install -C _build
+ DESTDIR="${pkgdir}" ninja -C build install
}