summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Goto2021-09-17 13:44:32 +0200
committerPhilip Goto2021-09-17 13:44:32 +0200
commit91f6c34005a0ea6fdfdd2c2747e32d51f1756142 (patch)
treedd85567cdf03e690f2ae31d66780a3588aaea86d
parent798ec877187dd0ee9531bbb6c6fc9641c21b8f16 (diff)
downloadaur-91f6c34005a0ea6fdfdd2c2747e32d51f1756142.tar.gz
Update URL and allow native wlroots installation
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD12
2 files changed, 11 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 68c7b1c6b669..1f74823f71fb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = phoc-embedded-wlroots
pkgdesc = Wlroots based Phone compositor (matching wlroots embedded)
pkgver = 0.8.0
- pkgrel = 1
- url = https://source.puri.sm/Librem5/phoc
+ pkgrel = 2
+ url = https://gitlab.gnome.org/World/Phosh/phoc
arch = x86_64
arch = aarch64
license = GPL3
@@ -17,8 +17,7 @@ pkgbase = phoc-embedded-wlroots
depends = xcb-util-errors
provides = phoc
conflicts = phoc
- conflicts = wlroots
- source = git+https://source.puri.sm/Librem5/phoc.git#tag=v0.8.0
+ source = git+https://gitlab.gnome.org/World/Phosh/phoc.git#tag=v0.8.0
source = git+https://source.puri.sm/Librem5/wlroots.git
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 06b6ff5f4171..61c2e07dc9ae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,9 @@
pkgname=phoc-embedded-wlroots
pkgver=0.8.0
-pkgrel=1
+pkgrel=2
pkgdesc='Wlroots based Phone compositor (matching wlroots embedded)'
-url='https://source.puri.sm/Librem5/phoc'
+url='https://gitlab.gnome.org/World/Phosh/phoc'
license=('GPL3')
arch=(x86_64 aarch64)
depends=(
@@ -21,7 +21,7 @@ makedepends=(
)
checkdepends=(xorg-server-xvfb)
provides=(phoc)
-conflicts=(phoc wlroots)
+conflicts=(phoc)
source=(
"git+${url}.git#tag=v${pkgver}"
"git+https://source.puri.sm/Librem5/wlroots.git"
@@ -32,7 +32,7 @@ prepare() {
cd phoc
git submodule init
- git submodule set-url subprojects/wlroots "$srcdir/wlroots"
+ git submodule set-url subprojects/wlroots "${srcdir}/wlroots"
git submodule update
}
@@ -49,4 +49,8 @@ check() {
package() {
DESTDIR="${pkgdir}" meson install -C build
+
+ rm -rf "${pkgdir}/usr/include/"
+ rm -rf "${pkgdir}/usr/lib/pkgconfig/"
+
}