summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Booker2022-08-24 20:49:35 +1200
committerThomas Booker2022-08-24 20:49:35 +1200
commitc34baeceda49a6bba9df0ac4e94b49c301363d4d (patch)
treeb73d1969cb831f09d65418547ea68044cb9b3f79
parent3e3844dccf801d4aa36bd4d4bf397c0adfc65dcd (diff)
downloadaur-c34baeceda49a6bba9df0ac4e94b49c301363d4d.tar.gz
Updated for 0.21.0 and changed some build configs
Changed the maintainer to Thomas Booker Use git commit hash, not tags Don't need to set the submodule folder, just pull it Changed the build folder to _build
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD32
2 files changed, 23 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b56a1ed739cc..56fd8632da31 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = phoc-embedded-wlroots
- pkgdesc = Wlroots based Phone compositor (matching wlroots embedded)
- pkgver = 0.21.beta1
+ pkgdesc = A pure Wayland shell prototype for GNOME on mobile devices (wlroots embedded)
+ pkgver = 0.21.0
pkgrel = 1
url = https://gitlab.gnome.org/World/Phosh/phoc
arch = x86_64
arch = aarch64
+ arch = armv7h
license = GPL3
makedepends = ctags
makedepends = git
@@ -13,17 +14,15 @@ pkgbase = phoc-embedded-wlroots
makedepends = vala
makedepends = vulkan-headers
makedepends = wayland-protocols
- depends = mutter
depends = seatd
depends = xcb-util-errors
depends = xcb-util-renderutil
depends = xcb-util-wm
+ depends = gnome-desktop
provides = phoc
conflicts = phoc
conflicts = wlroots
- source = git+https://gitlab.gnome.org/World/Phosh/phoc.git#tag=v0.21.0_beta1
- source = git+https://source.puri.sm/Librem5/wlroots.git
- b2sums = SKIP
- b2sums = SKIP
+ source = git+https://gitlab.gnome.org/World/Phosh/phoc.git#tag=1a58a2363b686241647138a8822beac4f761f3fb
+ sha256sums = SKIP
pkgname = phoc-embedded-wlroots
diff --git a/PKGBUILD b/PKGBUILD
index c2b4efd81003..b56d1b8c10cc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,19 @@
-# Maintainer: Philip Goto <philip.goto@gmail.com>
+# Maintainer: Thomas Booker <tw.booker@outlook.com>
+# Contributor: Philip Goto <philip.goto@gmail.com>
pkgname=phoc-embedded-wlroots
-pkgver=0.21.beta1
+pkgver=0.21.0
pkgrel=1
-pkgdesc='Wlroots based Phone compositor (matching wlroots embedded)'
-arch=(x86_64 aarch64)
+pkgdesc='A pure Wayland shell prototype for GNOME on mobile devices (wlroots embedded)'
+arch=(x86_64 aarch64 armv7h)
url='https://gitlab.gnome.org/World/Phosh/phoc'
license=(GPL3)
depends=(
- mutter
seatd
xcb-util-errors
xcb-util-renderutil
xcb-util-wm
+ gnome-desktop
)
makedepends=(
ctags
@@ -25,26 +26,27 @@ makedepends=(
)
provides=(phoc)
conflicts=(phoc wlroots)
-_commit=0.21.0_beta1
-source=(
- "git+${url}.git#tag=v${_commit}"
- "git+https://source.puri.sm/Librem5/wlroots.git"
-)
-b2sums=('SKIP' 'SKIP')
+_tag=1a58a2363b686241647138a8822beac4f761f3fb
+source=("git+${url}.git#tag=${_tag}")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd phoc
+ git describe --tags | sed 's/^v//'
+}
prepare() {
cd phoc
git submodule init
- git submodule set-url subprojects/wlroots "${srcdir}/wlroots"
git submodule update
}
build() {
- arch-meson phoc build -Dembed-wlroots=enabled
- meson compile -C build
+ arch-meson phoc _build -Dembed-wlroots=enabled -Dtests=false
+ meson compile -C _build
}
package() {
- DESTDIR="${pkgdir}" meson install -C build
+ DESTDIR="${pkgdir}" meson install -C _build
}