summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Goto2021-06-08 17:43:29 +0200
committerPhilip Goto2021-06-08 17:43:29 +0200
commitc6ad2836e0926166cf1876bfccdef477a63bf598 (patch)
tree936b7f316b00a2c4bc3e496d3ed90bc4fb4404ef
downloadaur-c6ad2836e0926166cf1876bfccdef477a63bf598.tar.gz
Initialize
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD52
2 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7d81f671acbc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = phoc-embedded-wlroots
+ pkgdesc = Wlroots based Phone compositor (matching wlroots embedded)
+ pkgver = 0.7.0
+ pkgrel = 1
+ url = https://source.puri.sm/Librem5/phoc
+ arch = x86_64
+ arch = aarch64
+ license = GPL3
+ checkdepends = xorg-server-xvfb
+ makedepends = ctags
+ makedepends = git
+ makedepends = libhandy
+ makedepends = meson
+ makedepends = vala
+ depends = mutter
+ depends = xcb-util-wm
+ depends = xcb-util-errors
+ provides = phoc
+ conflicts = phoc
+ conflicts = wlroots
+ source = git+https://source.puri.sm/Librem5/phoc.git#tag=v0.7.0
+ source = git+https://source.puri.sm/Librem5/wlroots.git
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = phoc-embedded-wlroots
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6dfdcea3f0dd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Philip Goto <philip.goto@gmail.com>
+
+pkgname=phoc-embedded-wlroots
+pkgver=0.7.0
+pkgrel=1
+pkgdesc='Wlroots based Phone compositor (matching wlroots embedded)'
+url='https://source.puri.sm/Librem5/phoc'
+license=('GPL3')
+arch=(x86_64 aarch64)
+depends=(
+ mutter
+ xcb-util-wm
+ xcb-util-errors
+)
+makedepends=(
+ ctags
+ git
+ libhandy
+ meson
+ vala
+)
+checkdepends=(xorg-server-xvfb)
+provides=(phoc)
+conflicts=(phoc wlroots)
+source=(
+ "git+${url}.git#tag=v${pkgver}"
+ "git+https://source.puri.sm/Librem5/wlroots.git"
+)
+sha256sums=('SKIP' 'SKIP')
+
+prepare() {
+ cd phoc
+
+ git submodule init
+ git submodule set-url subprojects/wlroots "$srcdir/wlroots"
+ git submodule update
+}
+
+build() {
+ arch-meson phoc build -Dembed-wlroots=enabled
+ meson compile -C build
+}
+
+check() {
+ dbus-run-session xvfb-run \
+ -s '-screen 0 1920x1080x24 -nolisten local' \
+ meson test -C build --print-errorlogs
+}
+
+package() {
+ DESTDIR="${pkgdir}" meson install -C build
+}