aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp Schmitt2013-06-28 16:25:07 +0200
committerPhilipp Schmitt2013-06-28 16:25:07 +0200
commitbf6244f2a9af8a1515e03438c9d4227a77c94f7c (patch)
tree78728dac1824d56c2a3dcd85b5a8bca63d54ca61
downloadaur-bf6244f2a9af8a1515e03438c9d4227a77c94f7c.tar.gz
first commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD37
-rw-r--r--README.md0
-rw-r--r--phoebetria.install32
4 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b1399b9b9c03
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = phoebetria
+ pkgdesc = Controller software for the BitFenix Recon fan controller.
+ pkgver = 1.4
+ pkgrel = 1
+ url = http://phoebetria.com/
+ install = phoebetria.install
+ arch = x86_64
+ license = GPL
+ makedepends = gcc
+ depends = qt4
+ depends = rpmextract
+ depends = systemd-tools
+ depends = libusbx
+ source = http://downloads.sourceforge.net/project/phoebetria/phoebetria-fc17-1.4-0.src.rpm
+ sha1sums = 3221dfbda4e15ae1cffdbed3523fb78964df4d4a
+
+pkgname = phoebetria
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d8a624af51e6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Contributor: Philipp Schmitt (attentah@NOSPAM.gmail.com)
+
+pkgname=phoebetria
+pkgver=1.4
+pkgrel=1
+pkgdesc="Controller software for the BitFenix Recon fan controller."
+arch=('x86_64')
+url="http://phoebetria.com/"
+license=('GPL')
+depends=('qt4' 'rpmextract' 'systemd-tools' 'libusbx')
+makedepends=('gcc')
+install="$pkgname.install"
+source=(http://downloads.sourceforge.net/project/phoebetria/$pkgname-fc17-$pkgver-0.src.rpm)
+sha1sums=('3221dfbda4e15ae1cffdbed3523fb78964df4d4a')
+
+
+build() {
+ cd "$srcdir"
+ rpmextract.sh "$pkgname-fc17-$pkgver-0.src.rpm"
+ tar xvzf "$pkgname-$pkgver.tar.gz"
+ cd "$pkgname-$pkgver"
+ # Lowercase the binary name
+ sed -i 's/\(TARGET = \)P\(hoebetria\)/\1p\2/' Phoebetria.pro
+ sed -i 's/\(Exec=\)P\(hoebetria\)/\1p\2/' phoebetria.desktop
+ qmake-qt4 && make
+}
+
+check() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make -k check
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make INSTALL_ROOT="$pkgdir/" install
+}
+
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/README.md
diff --git a/phoebetria.install b/phoebetria.install
new file mode 100644
index 000000000000..61ebd2a0fc8e
--- /dev/null
+++ b/phoebetria.install
@@ -0,0 +1,32 @@
+post_install() {
+groupadd fancontrollers
+cat <<-EoM
+You may want to reload logout/reboot before lauching phoebetria for the first time: a new group (fancontrollers) and an udev rule have been added to your system.
+XMonad users: if main window isn't displayed or just "flashes", please edit \$XDG_CONFIG_HOME/Phoebetria/Phoebetria.ini and set minimizeToTray to false.
+Working Example:
+[UserPrefs]
+startMinimized=false
+minimizeToTray=false
+showTrayIconTooltips=true
+useLogScaleRpmSliders=true
+quitOnClose=true
+startupProfile=
+shutdownProfile=
+channelName_0=
+channelName_1=
+channelName_2=
+channelName_3=
+channelName_4=
+probeName_0=
+probeName_1=
+probeName_2=
+probeName_3=
+probeName_4=
+stylesheet=:/other/Phoebetria.qss
+EoM
+}
+
+post_remove() {
+ groupdel fancontrollers
+}
+