summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThanosApostolou2019-01-02 13:37:41 +0200
committerThanosApostolou2019-01-02 13:37:41 +0200
commitdafd7042698621b62f9934958f99b3ad486e862d (patch)
treed52f83e7e6d1babc25cb355b11a61e197ab035d2
parentccc5173e2373c11f0ad6124fdd12bee57278875d (diff)
downloadaur-dafd7042698621b62f9934958f99b3ad486e862d.tar.gz
fix launcher on wayland sessions
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
-rw-r--r--fix-launcher-on-wayland.patch8
3 files changed, 21 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e8dbc22daa0f..b30136405e5c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = phoenicis-playonlinux
pkgdesc = Phoenicis PlayOnLinux allows you to install and use non-native applications on linux
pkgver = 5.0_alpha2
- pkgrel = 1
+ pkgrel = 2
url = https://www.phoenicis.org/
arch = any
license = LGPL3
@@ -20,7 +20,9 @@ pkgbase = phoenicis-playonlinux
depends = xterm
options = !strip
source = https://github.com/PhoenicisOrg/phoenicis/archive/v5.0-alpha.2.tar.gz
+ source = fix-launcher-on-wayland.patch
sha256sums = c88b8ca68c0c37f62aad4db44cef0047c09e8fd553455af15ef3265b0e3c575b
+ sha256sums = f681160a361e84021cd9f0c272e9992eedb6950ffde49f335dec665232510ed7
pkgname = phoenicis-playonlinux
diff --git a/PKGBUILD b/PKGBUILD
index 8ee9c93f720f..0b3365bedbe9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgname=phoenicis-playonlinux
_pkgname=phoenicis
pkgver=5.0_alpha2
_pkgver=5.0-alpha.2
-pkgrel=1
+pkgrel=2
pkgdesc="Phoenicis PlayOnLinux allows you to install and use non-native applications on linux"
arch=('any')
url="https://www.phoenicis.org/"
@@ -17,8 +17,15 @@ depends=('cabextract' 'curl' 'icoutils' 'imagemagick'
'java-openjfx-bin' 'java-runtime-openjdk=11'
'p7zip' 'unzip' 'wget' 'wine' 'xterm')
options=(!strip)
-source=(https://github.com/PhoenicisOrg/${_pkgname}/archive/v${_pkgver}.tar.gz)
-sha256sums=('c88b8ca68c0c37f62aad4db44cef0047c09e8fd553455af15ef3265b0e3c575b')
+source=("https://github.com/PhoenicisOrg/${_pkgname}/archive/v${_pkgver}.tar.gz"
+ "fix-launcher-on-wayland.patch")
+sha256sums=('c88b8ca68c0c37f62aad4db44cef0047c09e8fd553455af15ef3265b0e3c575b'
+ 'f681160a361e84021cd9f0c272e9992eedb6950ffde49f335dec665232510ed7')
+
+prepare() {
+ cd "${_pkgname}-${_pkgver}"
+ patch -Np1 -i "${srcdir}/fix-launcher-on-wayland.patch"
+}
build() {
cd "${_pkgname}-${_pkgver}"
diff --git a/fix-launcher-on-wayland.patch b/fix-launcher-on-wayland.patch
new file mode 100644
index 000000000000..a6251506b524
--- /dev/null
+++ b/fix-launcher-on-wayland.patch
@@ -0,0 +1,8 @@
+diff -ura --color phoenicis-5.0-alpha.2.orig/phoenicis-dist/src/launchers/phoenicis phoenicis-5.0-alpha.2.new/phoenicis-dist/src/launchers/phoenicis
+--- phoenicis-5.0-alpha.2.orig/phoenicis-dist/src/launchers/phoenicis 2019-01-01 13:27:10.000000000 +0200
++++ phoenicis-5.0-alpha.2.new/phoenicis-dist/src/launchers/phoenicis 2019-01-02 13:30:53.836513144 +0200
+@@ -1,3 +1,3 @@
+ #!/bin/bash
+-
++export GDK_BACKEND=x11
+ /usr/share/phoenicis/PhoenicisPlayOnLinux "$@"