summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorViachaslau Khalikin2015-07-19 00:40:11 +0300
committerViachaslau Khalikin2015-07-19 00:40:11 +0300
commit8ace82b8e21c5f5c637a31309deaa6bcdafe62e9 (patch)
tree2e4045e57e841de297b3b3a78abf7934c6f3193d
downloadaur-8ace82b8e21c5f5c637a31309deaa6bcdafe62e9.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD26
-rw-r--r--phoenix-emu-project.desktop12
-rw-r--r--phoenix-emu-project.install10
4 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..34221ee13464
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = phoenix-emu-project
+ pkgdesc = An emulator of 3DO consoles. 100% compatible!
+ pkgver = 2.3.1
+ pkgrel = 1
+ url = http://www.arts-union.ru/node/23
+ install = phoenix-emu-project.install
+ arch = x86_64
+ license = custom
+ depends = qt5-base
+ depends = openal
+ depends = glu
+ source = http://www.arts-union.ru/sites/default/files/ph231-linux-x64.zip
+ source = phoenix-emu-project.desktop
+ md5sums = 012f380ab8842c8fde4912e49d380ce7
+ md5sums = 7f9b5652c512887d7e034cc8c07b2045
+
+pkgname = phoenix-emu-project
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3aba5556235b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Viachaslau Khalikin <vkhinegret@gmail.com>
+
+pkgname=phoenix-emu-project
+pkgver=2.3.1
+pkgrel=1
+pkgdesc="An emulator of 3DO consoles. 100% compatible!"
+url="http://www.arts-union.ru/node/23"
+license=('custom')
+arch=('x86_64')
+depends=('qt5-base' 'openal' 'glu')
+install="phoenix-emu-project.install"
+source=("http://www.arts-union.ru/sites/default/files/ph231-linux-x64.zip"
+ phoenix-emu-project.desktop)
+md5sums=('012f380ab8842c8fde4912e49d380ce7'
+ '7f9b5652c512887d7e034cc8c07b2045')
+package() {
+ cd "$srcdir"
+ # about licenses
+ install -d "$pkgdir/usr/share/licenses/phoenix-emu-project"
+ install -m644 licenses.txt "$pkgdir/usr/share/licenses/phoenix-emu-project"
+ # startup script and executable
+ install -Dm755 PhoenixEmuProject-2.3.1 "$pkgdir/usr/bin/phoenix-emu-project"
+ # desktop icon
+ install -Dm645 phoenix-emu-project.desktop "$pkgdir/usr/share/applications/phoenix-emu-project.desktop"
+ install -Dm644 logo.png "$pkgdir/usr/share/pixmaps/phoenix-emu-project-logo.png"
+}
diff --git a/phoenix-emu-project.desktop b/phoenix-emu-project.desktop
new file mode 100644
index 000000000000..6c35475307fa
--- /dev/null
+++ b/phoenix-emu-project.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Exec=phoenix-emu-project
+
+Name=PhoenixEmuProject
+GenericName=3DO consoles Emulator
+Comment=An emulator of 3DO consoles
+Icon=phoenix-emu-project-logo
+
+Categories=Game;Emulator;
+
diff --git a/phoenix-emu-project.install b/phoenix-emu-project.install
new file mode 100644
index 000000000000..158e41df1b00
--- /dev/null
+++ b/phoenix-emu-project.install
@@ -0,0 +1,10 @@
+post_install () {
+ echo -e "\t\033[0;31mNote\033[0m"
+ echo -e "\tNow most of the interface is only available in Russian."
+ echo -e "\tHowever, the developer plans to implement a multilanguage interface."
+}
+post_upgrade () {
+ echo -e "\t\033[0;31mNote\033[0m"
+ echo -e "\tNow most of the interface is only available in Russian."
+ echo -e "\tHowever, the developer plans to implement a multilanguage interface."
+}