summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2018-09-14 23:36:06 +0200
committerbartus2018-09-14 23:36:06 +0200
commitb0b5865cc8280e52720d7ded0b952577495d395c (patch)
treee927e78e582759bc9a25b4fc8850502bee18385b
parent1f754305a6a55b5befdb6e4e66c0fe521cdab8fb (diff)
downloadaur-b0b5865cc8280e52720d7ded0b952577495d395c.tar.gz
resolve build dep cycle.
move backend from dependends to optdepends. add post_install message to warn user of missing dependency.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
-rw-r--r--phonon-qt4.install15
3 files changed, 23 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7d131e792d74..97bb88753219 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,6 +3,7 @@ pkgbase = phonon-qt4
pkgver = 4.10.1
pkgrel = 3
url = http://phonon.kde.org/
+ install = phonon-qt4.install
arch = x86_64
license = LGPL
makedepends = extra-cmake-modules
@@ -18,5 +19,6 @@ pkgbase = phonon-qt4
pkgname = phonon-qt4
depends = qt4
depends = libpulse
- depends = phonon-qt4-backend
+ optdepends = pulseaudio: PulseAudio support
+ optdepends = phonon-qt4-backend: !!! REQUIRED FOR PHONO TO WORK AT ALL !!!
diff --git a/PKGBUILD b/PKGBUILD
index a420acdea679..99bac6ba7f2b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,8 +7,10 @@ arch=(x86_64)
optdepends=('pulseaudio: PulseAudio support')
makedepends=(extra-cmake-modules libpulse qt4)
url='http://phonon.kde.org/'
+install="phonon-qt4.install"
license=(LGPL)
-source=("https://download.kde.org/stable/${pkgname%-qt4}/$pkgver/${pkgname%-qt4}-$pkgver.tar.xz"{,.sig})
+source=("https://download.kde.org/stable/${pkgname%-qt4}/$pkgver/${pkgname%-qt4}-$pkgver.tar.xz"{,.sig}
+ )
sha256sums=('e5a98df31aeffc22493afc8d6adbca5d6f0c27cc2eed73b3be05195321e08db7'
'SKIP')
validpgpkeys=(CB9387521E1EE0127DA804843FDBB55084CC5D84) # Harald Sitter <sitter@kde.org>
@@ -30,7 +32,8 @@ build() {
package(){
- depends=(qt4 libpulse phonon-qt4-backend)
+ depends=(qt4 libpulse)
+ optdepends+=('phonon-qt4-backend: !!! REQUIRED FOR PHONO TO WORK AT ALL !!!')
cd build
make DESTDIR="$pkgdir" install
diff --git a/phonon-qt4.install b/phonon-qt4.install
new file mode 100644
index 000000000000..8301b8c3bc1f
--- /dev/null
+++ b/phonon-qt4.install
@@ -0,0 +1,15 @@
+all_off="$(tput sgr0)"
+bold="${all_off}$(tput bold)"
+yellow="${bold}$(tput setaf 3)"
+blue="${bold}$(tput setaf 4)"
+green="${bold}$(tput setaf 2)"
+
+post_install() {
+ printf "${yellow}==>${all_off} ${bold}ATENTION:${all_off}
+${green}==>${all_off} ${bold} This package has an essential dependencies set to optional ${all_off}(those resolving build dependency cycle).
+ ${blue}->${all_off} You need to install one of ${bold}phonon-qt4-backend${all_off} for phonon to work at all.
+ ${yellow}.${all_off} phonon-qt4-gstreamer
+ ${yellow}.${all_off} phonon-qt4-mplayer
+ ${yellow}.${all_off} phonon-qt4-vlc
+"
+}