summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072019-03-18 16:57:24 +0100
committersL1pKn072019-03-18 16:57:24 +0100
commit8e166c834a39279bcd79bf336b630765cc7e2575 (patch)
tree4caee3438196544c83985e4d2cf5cbae1cc4f815
downloadaur-8e166c834a39279bcd79bf336b630765cc7e2575.tar.gz
Initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD47
3 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7acdc8173077
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Mon Mar 18 15:57:24 UTC 2019
+pkgbase = phonon-qt5-mpv-git
+ pkgdesc = Phonon Backend using MPV Player. (GIT version)
+ pkgver = v0.0.5.0.gffcffc4
+ pkgrel = 1
+ url = https://github.com/OpenProgger/phonon-mpv
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ makedepends = git
+ makedepends = qt5-tools
+ depends = mpv
+ depends = phonon-qt5
+ depends = qt5-x11extras
+ provides = phonon-qt5-backend
+ conflicts = phonon-qt5-mpv
+ replaces = phonon-qt5-mpv
+ source = git+https://github.com/OpenProgger/phonon-mpv.git
+ sha256sums = SKIP
+
+pkgname = phonon-qt5-mpv-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2a525c4c0041
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+pkgname=phonon-qt5-mpv-git
+pkgver=v0.0.5.0.gffcffc4
+pkgrel=1
+pkgdesc="Phonon Backend using MPV Player. (GIT version)"
+arch=('x86_64')
+url='https://github.com/OpenProgger/phonon-mpv'
+license=('GPL')
+depends=('mpv'
+ 'phonon-qt5'
+ 'qt5-x11extras'
+ )
+makedepends=('cmake'
+ 'git'
+ 'qt5-tools'
+ )
+provides=('phonon-qt5-backend')
+conflicts=('phonon-qt5-mpv')
+replaces=('phonon-qt5-mpv')
+source=('git+https://github.com/OpenProgger/phonon-mpv.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd phonon-mpv
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ cmake ../phonon-mpv \
+ -DCMAKE_BUILD_TYPE=Mone \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=/usr/lib \
+ -DCMAKE_SKIP_RPATH=ON
+
+ make
+}
+
+
+package () {
+ make -C build DESTDIR="${pkgdir}" install
+}