summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAustin Haedicke2018-08-18 15:17:34 -0400
committerAustin Haedicke2018-08-18 15:17:34 -0400
commit176a89b79c9678e8edb51418ba7c196eb36a5652 (patch)
treee3a63976736ddd9fa54c89fcb78f53b6d4fd9ce6
parenta823e2ef13bf78076449127b5b96714c65227ced (diff)
downloadaur-176a89b79c9678e8edb51418ba7c196eb36a5652.tar.gz
improved pacakge(), source(), and pkgver() from Fabio Loli
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
-rw-r--r--phoronix-test-suite-git.install9
3 files changed, 14 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 33dc6e307356..86872cf70c10 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = phoronix-test-suite-git
pkgdesc = The most comprehensive testing and benchmarking platform available for Linux
- pkgver = 8.0.1.r56.g24ecd03a9
- pkgrel = 1
+ pkgver = 8.2.0m2.r7.g642feee05
+ pkgrel = 2
url = http://www.phoronix-test-suite.com/
install = phoronix-test-suite-git.install
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index 4ce1f68390cc..62cd71930b3d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@
# or submit a pull request @ https://gtbjj.com/savagezen/pkgbuild
pkgname=phoronix-test-suite-git
-pkgver=8.0.1.r56.g24ecd03a9
-pkgrel=1
+pkgver=8.2.0m2.r7.g642feee05
+pkgrel=2
pkgdesc="The most comprehensive testing and benchmarking platform available for Linux"
arch=('any')
license=('GPL3')
@@ -50,5 +50,8 @@ package() {
install -D "${srcdir}/${pkgname}"/pts-core/external-test-dependencies/xml/arch-packages.xml \
"${pkgdir}"/usr/share/phoronix-test-suite/pts-core/external-test-dependencies/xml/arch-packages.xml
+ install -D "${srcdir}/phoronix-test-suite-${pkgver}"/pts-core/external-test-dependencies/xml/generic-packages.xml \
+ "${pkgdir}"/usr/share/phoronix-test-suite/pts-core/external-test-dependencies/xml/generic-packages.xml
+
sed -e "s/^export PTS_DIR=.*/export PTS_DIR=\/usr\/share\/phoronix-test-suite/g" -i ${pkgdir}/usr/bin/phoronix-test-suite
}
diff --git a/phoronix-test-suite-git.install b/phoronix-test-suite-git.install
index 30c359b93395..3fbe65ebd7a5 100644
--- a/phoronix-test-suite-git.install
+++ b/phoronix-test-suite-git.install
@@ -1,4 +1,9 @@
post_install() {
- gtk-update-icon cache -q -t -f /usr/share/icons/hicolor
- update-desktop-database -q
+ echo ">>>"
+ echo ">>> To complete the installation you should edit /etc/php/php.ini"
+ echo ">>> - Enable zip.so, sockets.so"
+ echo ">>>"
+ echo ">>> EXAMPLE:"
+ echo ">>> extension=zip.so"
+ echo ">>> extension=sockets.so"
}