summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAustin Haedicke2018-06-07 18:38:08 -0400
committerAustin Haedicke2018-06-07 18:38:08 -0400
commit1d510ccc33c19b05b2516506fd6614e0f9f80e16 (patch)
treee00bbda0646302440c2e2c7798dc8e6db5281085
parent105fd9b2c5564fe361aeb0320b3d2a412335d7ee (diff)
downloadaur-1d510ccc33c19b05b2516506fd6614e0f9f80e16.tar.gz
phoronix-test-suite-git general update
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD33
2 files changed, 40 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1ae699f022d..d206f21198b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,26 @@
pkgbase = phoronix-test-suite-git
pkgdesc = The most comprehensive testing and benchmarking platform available for Linux
- pkgver = v5.8.1.1.ge6fbee9
+ pkgver = 8.0.0.r0.g81f7c7bed
pkgrel = 1
url = http://www.phoronix-test-suite.com/
- arch = i686
- arch = x86_64
- license = GPL
+ install = phoronix-test-suite-git.install
+ arch = any
+ license = GPL3
makedepends = git
- depends = desktop-file-utils
- depends = hicolor-icon-theme
- depends = python
- depends = ruby
- optdepends = php
- optdepends = php-gtk
- optdepends = php-curl
+ depends = php
+ optdepends = python
optdepends = php-gd
- source = https://github.com/phoronix-test-suite/phoronix-test-suite.git
+ optdepends = sqlite3: required when running a Phoromatic server.
+ optdepends = gcc-fortran: required for universe-cli test suite
+ optdepends = blas: required for universe-cli test suite
+ optdepends = lapack: required for universe-cli test suite
+ optdepends = portaudio: required for universe-cli test suite
+ optdepends = unzip: required for universe-cli test suite
+ optdepends = mesa-demos: required for universe-cli test suite
+ optdepends = openmpi: required for universe-cli test suite
+ provides = phoronix-test-suite
+ conflicts = phoronix-test-suite
+ source = phoronix-test-suite-git::git://github.com/phoronix-test-suite/phoronix-test-suite.git
md5sums = SKIP
pkgname = phoronix-test-suite-git
diff --git a/PKGBUILD b/PKGBUILD
index 45baf547096..4e68592b302 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,29 +3,42 @@
# If you find errors or have suggestions feel free to file an issue
# or submit a pull request @ https://gtbjj.com/savagezen/pkgbuild
-_pkgname=phoronix-test-suite
pkgname=phoronix-test-suite-git
-pkgver=v7.2.1.1.g38b36330d
+pkgver=8.0.0.r0.g81f7c7bed
pkgrel=1
pkgdesc="The most comprehensive testing and benchmarking platform available for Linux"
-arch=('i686' 'x86_64')
-license=('GPL')
+arch=('any')
+license=('GPL3')
url="http://www.phoronix-test-suite.com/"
-depends=('ruby' 'python')
+depends=('php')
makedepends=('git')
-optdepends=('php' 'php-gtk')
+optdepends=('python'
+ 'php-gd'
+ 'sqlite3: required when running a Phoromatic server.'
+ 'gcc-fortran: required for universe-cli test suite'
+ 'blas: required for universe-cli test suite'
+ 'lapack: required for universe-cli test suite'
+ 'portaudio: required for universe-cli test suite'
+ 'unzip: required for universe-cli test suite'
+ 'mesa-demos: required for universe-cli test suite'
+ 'openmpi: required for universe-cli test suite')
provides=('phoronix-test-suite')
conflicts=('phoronix-test-suite')
install=$pkgname.install
-source=("git://github.com/phoronix-test-suite/phoronix-test-suite.git")
+source=("$pkgname::git://github.com/phoronix-test-suite/phoronix-test-suite.git")
md5sums=('SKIP')
pkgver() {
- cd $_pkgname
- git describe --always | sed -e 's|-|.|g'
+ cd "$pkgname"
+ git describe --long --tags | sed 's/v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
package() {
- cd $srcdir/$_pkgname
+ cd "$srcdir/$pkgname"
./install-sh $pkgdir/usr
+
+ rm -r "${pkgdir}"/usr/share/phoronix-test-suite/deploy
+
+ sed -i "s#--noconfirm#--noconfirm --asdeps#" ${pkgdir}/usr/share/phoronix-test-suite/pts-core/external-test-dependencies/scripts/install-arch-packages.sh
+ sed -e "s/^export PTS_DIR=.*/export PTS_DIR=\/usr\/share\/phoronix-test-suite/g" -i ${pkgdir}/usr/bin/phoronix-test-suite
}