summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgrandtheftjiujitsu2015-06-25 12:39:31 -0400
committergrandtheftjiujitsu2015-06-25 12:39:31 -0400
commite9a6cc3396d5dfe0087b010d6f5a25df88926e24 (patch)
tree03d7b237cace1715e4ea922e9bf40e1899f0be4f
downloadaur-e9a6cc3396d5dfe0087b010d6f5a25df88926e24.tar.gz
Initial Import
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD27
-rw-r--r--phoronix-test-suite-git.install4
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1ae699f022d4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = phoronix-test-suite-git
+ pkgdesc = The most comprehensive testing and benchmarking platform available for Linux
+ pkgver = v5.8.1.1.ge6fbee9
+ pkgrel = 1
+ url = http://www.phoronix-test-suite.com/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = desktop-file-utils
+ depends = hicolor-icon-theme
+ depends = python
+ depends = ruby
+ optdepends = php
+ optdepends = php-gtk
+ optdepends = php-curl
+ optdepends = php-gd
+ source = https://github.com/phoronix-test-suite/phoronix-test-suite.git
+ md5sums = SKIP
+
+pkgname = phoronix-test-suite-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..199196359c78
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Austin Haedicke <gtbb on irc #archlinux>
+
+_pkgname=phoronix-test-suite
+pkgname=phoronix-test-suite-git
+pkgver=v5.8.1.1.ge6fbee9
+pkgrel=1
+pkgdesc="The most comprehensive testing and benchmarking platform available for Linux"
+arch=('i686' 'x86_64')
+license=('GPL')
+url="http://www.phoronix-test-suite.com/"
+depends=('desktop-file-utils' 'hicolor-icon-theme' 'python' 'ruby')
+makedepends=('git')
+optdepends=('php' 'php-gtk' 'php-curl' 'php-gd')
+source=("https://github.com/phoronix-test-suite/phoronix-test-suite.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ git describe --always | sed -e 's|-|.|g'
+}
+
+package() {
+ cd $srcdir/$_pkgname
+ mkdir -p $pkgdir/usr/bin
+ ./install-sh ${pkgdir}/usr
+# xdg-icon-resource forceupdate
+}
diff --git a/phoronix-test-suite-git.install b/phoronix-test-suite-git.install
new file mode 100644
index 000000000000..dd1b5e4caaff
--- /dev/null
+++ b/phoronix-test-suite-git.install
@@ -0,0 +1,4 @@
+To Complete the Installation:
+
+Update your icons:
+ $ xdg-icon-resource forceupdate