summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Goto2021-05-24 14:15:48 +0200
committerPhilip Goto2021-05-24 14:15:48 +0200
commit8c8a3e2a8fdb8ddb52c9f112e1b9213cc5c06755 (patch)
tree3d07e65fa9a9ee525432eeced9bfc450e1df221b
parentefb850a63e3dd1a3a1c92c8f2f85be14ed9fb060 (diff)
downloadaur-8c8a3e2a8fdb8ddb52c9f112e1b9213cc5c06755.tar.gz
Set wlroots version dependency
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD9
-rw-r--r--wlroots.patch33
3 files changed, 6 insertions, 43 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9ee94d0521ad..a70ba47efebb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = phosh
pkgdesc = A pure Wayland shell prototype for GNOME on mobile devices
pkgver = 0.10.2
- pkgrel = 1
+ pkgrel = 2
url = https://source.puri.sm/Librem5/phosh
arch = i686
arch = x86_64
@@ -16,11 +16,10 @@ pkgbase = phosh
depends = feedbackd
depends = libhandy
depends = phoc
- depends = libwlroots.so=7
+ depends = wlroots>=0.10
+ depends = wlroots<0.11
source = git+https://source.puri.sm/Librem5/phosh.git#tag=v0.10.2
source = git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git
- source = file://wlroots.patch
- sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 1f6032f899ff..dcbf5ae7f762 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=phosh
pkgver=0.10.2
-pkgrel=1
+pkgrel=2
pkgdesc="A pure Wayland shell prototype for GNOME on mobile devices"
url="https://source.puri.sm/Librem5/phosh"
license=("GPL3")
@@ -11,7 +11,7 @@ depends=(
feedbackd
libhandy
phoc
- libwlroots.so=7
+ 'wlroots>=0.10' 'wlroots<0.11'
)
makedepends=(
ctags
@@ -23,9 +23,8 @@ checkdepends=(xorg-server-xvfb)
source=(
"git+${url}.git#tag=v${pkgver}"
"git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git"
- "file://wlroots.patch"
)
-sha256sums=('SKIP' 'SKIP' 'SKIP')
+sha256sums=('SKIP' 'SKIP')
prepare() {
cd phosh
@@ -33,8 +32,6 @@ prepare() {
git submodule init
git config --local submodule.subprojects/gvc.url "$srcdir/libgnome-volume-control"
git submodule update
-
- patch src/home.c ../wlroots.patch
}
build() {
diff --git a/wlroots.patch b/wlroots.patch
deleted file mode 100644
index 58cca308a24c..000000000000
--- a/wlroots.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From 87399f9e40c8475004924732432e677356edfa36 Mon Sep 17 00:00:00 2001
-From: Sebastian Krzyszkowiak <sebastian.krzyszkowiak@puri.sm>
-Date: Wed, 11 Nov 2020 05:35:28 +0100
-Subject: [PATCH] home test
-
----
- src/home.c | 3 +++
- 1 file changed, 3 insertions(+)
-
-diff --git a/src/home.c b/src/home.c
-index 417be36..44de64d 100644
---- a/src/home.c
-+++ b/src/home.c
-@@ -387,6 +387,8 @@ GtkWidget *
- phosh_home_new (struct zwlr_layer_shell_v1 *layer_shell,
- struct wl_output *wl_output)
- {
-+ int height;
-+ phosh_shell_get_usable_area (phosh_shell_get_default (), NULL, NULL, NULL, &height);
- return g_object_new (PHOSH_TYPE_HOME,
- "layer-shell", layer_shell,
- "wl-output", wl_output,
-@@ -396,6 +398,7 @@ phosh_home_new (struct zwlr_layer_shell_v1 *layer_shell,
- "layer", ZWLR_LAYER_SHELL_V1_LAYER_TOP,
- "kbd-interactivity", FALSE,
- "exclusive-zone", PHOSH_HOME_BUTTON_HEIGHT,
-+ "height", height + PHOSH_HOME_BUTTON_HEIGHT,
- "namespace", "phosh home",
- NULL);
- }
---
-2.26.2
-