summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Booker2023-02-26 18:39:54 +1300
committerThomas Booker2023-02-26 18:39:54 +1300
commitb5b7848a90601564f6dcea2d1f6abbe351c4246b (patch)
tree606d74277377a3febc996f9a7bb6ec1e7e4c3fec
parentee0e16c8c042bc7112d01e188e0a0704738a21b6 (diff)
downloadaur-b5b7848a90601564f6dcea2d1f6abbe351c4246b.tar.gz
Update to 0.24.0 from 0.21.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD17
2 files changed, 18 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 43f3ecc2e948..c2ca38c12359 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = phosh
pkgdesc = A pure Wayland shell prototype for GNOME on mobile devices
- pkgver = 0.21.0
+ pkgver = 0.24.0
pkgrel = 1
url = https://gitlab.gnome.org/World/Phosh/phosh
arch = x86_64
@@ -20,11 +20,15 @@ pkgbase = phosh
depends = feedbackd
depends = libnm
depends = evolution-data-server
- depends = phoc-embedded-wlroots>=0.21.0
+ depends = phoc-embedded-wlroots
depends = gnome-shell
depends = callaudiod
depends = polkit
- source = git+https://gitlab.gnome.org/World/Phosh/phosh.git#tag=4122630266abfd6623e169330da6e7d6bc01be7f
+ depends = libadwaita
+ depends = evince
+ source = git+https://gitlab.gnome.org/World/Phosh/phosh.git#tag=81ec8c86
+ source = pam_phosh
sha256sums = SKIP
+ sha256sums = b7793f80c533e84ad8adfe8bb46c69f107575e724aa9b53b41f370baa37e4fd5
pkgname = phosh
diff --git a/PKGBUILD b/PKGBUILD
index daac2e895595..97ba024ce70c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Philip Goto <philip.goto@gmail.com>
pkgname=phosh
-pkgver=0.21.0
+pkgver=0.24.0
pkgrel=1
pkgdesc='A pure Wayland shell prototype for GNOME on mobile devices'
arch=(x86_64 aarch64 armv7h)
@@ -21,17 +21,19 @@ depends=(
evolution-data-server
# Replace this with phoc once it works.
#'phoc>=0.21.0'
- 'phoc-embedded-wlroots>=0.21.0'
+ phoc-embedded-wlroots
gnome-shell
callaudiod
polkit
+ libadwaita
+ evince
)
makedepends=(
meson
git
wayland-protocols
)
-_tag=4122630266abfd6623e169330da6e7d6bc01be7f # git rev-parse v${pkgver}
+_tag=81ec8c86 # git rev-parse v${pkgver}
source=(
"git+${url}.git#tag=${_tag}"
"pam_phosh"
@@ -49,16 +51,19 @@ pkgver() {
prepare() {
cd phosh
- git submodule init
- git submodule update
+ git submodule update --init
}
build() {
# If we don't set `libexecdir` then meson will try and place the phosh bin in /lib/phosh and collide with the dir so we put it in /lib/phosh/phosh
- arch-meson --libexecdir="/usr/lib/phosh" -D tests=false -D systemd=true phosh _build
+ arch-meson --libexecdir="/usr/lib/phosh" -D tests=true -D phoc_tests=disabled -D man=true -D gtk_doc=false -D callui-i18n=true -D lockscreen-plugins=true -D systemd=true phosh _build
meson compile -C _build
}
+check() {
+ xvfb-run meson test --no-suite screenshots -C _build
+}
+
package() {
DESTDIR="${pkgdir}" meson install -C _build