summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Goto2021-04-13 13:46:11 +0200
committerPhilip Goto2021-04-13 13:46:11 +0200
commitbfce25388cab26e4bcbeaafc3d651fa988dcd37e (patch)
tree87dbb5d8116b23ae40b6a2cd9f7a03afa3bd2fd4
parent4290a21ed9e77ad7853b2f9f68b5dba0ab9dd74e (diff)
downloadaur-bfce25388cab26e4bcbeaafc3d651fa988dcd37e.tar.gz
Update to 0.10.1
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD7
-rw-r--r--wlroots.patch33
3 files changed, 43 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1b84847d6ead..32300d8ba401 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = phosh
pkgdesc = A pure Wayland shell prototype for GNOME on mobile devices
- pkgver = 0.10.0
+ pkgver = 0.10.1
pkgrel = 1
url = https://source.puri.sm/Librem5/phosh
arch = i686
@@ -8,6 +8,7 @@ pkgbase = phosh
arch = armv7h
arch = aarch64
license = GPL3
+ checkdepends = xorg-server-xvfb
makedepends = ctags
makedepends = git
makedepends = meson
@@ -15,8 +16,10 @@ pkgbase = phosh
depends = feedbackd
depends = libhandy
depends = phoc
- source = git+https://source.puri.sm/Librem5/phosh.git#tag=v0.10.0
+ source = git+https://source.puri.sm/Librem5/phosh.git#tag=v0.10.1
source = git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git
+ source = file://wlroots.patch
+ sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index d169486bc3a8..c83c3f24da8c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Philip Goto <philip.goto@gmail.com>
pkgname=phosh
-pkgver=0.10.0
+pkgver=0.10.1
pkgrel=1
pkgdesc="A pure Wayland shell prototype for GNOME on mobile devices"
url="https://source.puri.sm/Librem5/phosh"
@@ -22,8 +22,9 @@ checkdepends=(xorg-server-xvfb)
source=(
"git+${url}.git#tag=v${pkgver}"
"git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git"
+ "file://wlroots.patch"
)
-sha256sums=('SKIP' 'SKIP')
+sha256sums=('SKIP' 'SKIP' 'SKIP')
prepare() {
cd phosh
@@ -31,6 +32,8 @@ prepare() {
git submodule init
git config --local submodule.subprojects/gvc.url "$srcdir/libgnome-volume-control"
git submodule update
+
+ patch src/home.c ../wlroots.patch
}
build() {
diff --git a/wlroots.patch b/wlroots.patch
new file mode 100644
index 000000000000..58cca308a24c
--- /dev/null
+++ b/wlroots.patch
@@ -0,0 +1,33 @@
+From 87399f9e40c8475004924732432e677356edfa36 Mon Sep 17 00:00:00 2001
+From: Sebastian Krzyszkowiak <sebastian.krzyszkowiak@puri.sm>
+Date: Wed, 11 Nov 2020 05:35:28 +0100
+Subject: [PATCH] home test
+
+---
+ src/home.c | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/src/home.c b/src/home.c
+index 417be36..44de64d 100644
+--- a/src/home.c
++++ b/src/home.c
+@@ -387,6 +387,8 @@ GtkWidget *
+ phosh_home_new (struct zwlr_layer_shell_v1 *layer_shell,
+ struct wl_output *wl_output)
+ {
++ int height;
++ phosh_shell_get_usable_area (phosh_shell_get_default (), NULL, NULL, NULL, &height);
+ return g_object_new (PHOSH_TYPE_HOME,
+ "layer-shell", layer_shell,
+ "wl-output", wl_output,
+@@ -396,6 +398,7 @@ phosh_home_new (struct zwlr_layer_shell_v1 *layer_shell,
+ "layer", ZWLR_LAYER_SHELL_V1_LAYER_TOP,
+ "kbd-interactivity", FALSE,
+ "exclusive-zone", PHOSH_HOME_BUTTON_HEIGHT,
++ "height", height + PHOSH_HOME_BUTTON_HEIGHT,
+ "namespace", "phosh home",
+ NULL);
+ }
+--
+2.26.2
+