summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Goto2020-11-30 15:36:29 +0100
committerPhilip Goto2020-11-30 15:36:29 +0100
commitc19a79a7eba89509a2d3440f980ffbb6879990c4 (patch)
treec70e811204e9bef3dc4b07ba9c4a1768ab99062f
parent39e1d73dc1d0cbed7dbb79eef8055e55da7e4d89 (diff)
downloadaur-c19a79a7eba89509a2d3440f980ffbb6879990c4.tar.gz
Add workaround patch for newest wlroots
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD17
2 files changed, 15 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ac3815870c35..2f50eb836236 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = phosh
pkgdesc = A pure Wayland shell prototype for GNOME on mobile devices
pkgver = 0.6.0
- pkgrel = 1
+ pkgrel = 2
url = https://source.puri.sm/Librem5/phosh
arch = i686
arch = x86_64
@@ -17,6 +17,8 @@ pkgbase = phosh
depends = phoc
source = git+https://source.puri.sm/Librem5/phosh.git#tag=v0.6.0
source = git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git
+ source = wlroots.patch::https://source.puri.sm/sebastian.krzyszkowiak/phosh/-/commit/87399f9e40c8475004924732432e677356edfa36.patch
+ sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 930c94e9ea54..c5c73512749b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=phosh
pkgver=0.6.0
-pkgrel=1
+pkgrel=2
pkgdesc="A pure Wayland shell prototype for GNOME on mobile devices"
url="https://source.puri.sm/Librem5/phosh"
license=("GPL3")
@@ -14,9 +14,12 @@ makedepends=('ctags'
'git'
'meson'
'vala')
-source=("git+https://source.puri.sm/Librem5/phosh.git#tag=v${pkgver}"
- "git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git")
+# checkdepends=(xorg-server-xvfb)
+source=("git+${url}.git#tag=v${pkgver}"
+ "git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git"
+ "wlroots.patch::https://source.puri.sm/sebastian.krzyszkowiak/phosh/-/commit/87399f9e40c8475004924732432e677356edfa36.patch")
sha256sums=('SKIP'
+ 'SKIP'
'SKIP')
prepare() {
@@ -25,15 +28,19 @@ prepare() {
git submodule init
git config --local submodule.subprojects/gvc.url "$srcdir/libgnome-volume-control"
git submodule update
+
+ patch src/home.c ../wlroots.patch
}
build() {
- arch-meson phosh build # -Dtests=false
+ arch-meson phosh build
meson compile -C build
}
# check() {
-# meson test -C build --print-errorlogs
+# dbus-run-session xvfb-run \
+# -s '-screen 0 1920x1080x24 -nolisten local' \
+# meson test -C build --print-errorlogs
# }
package() {