summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Goto2021-01-06 00:15:10 +0100
committerPhilip Goto2021-01-06 00:15:10 +0100
commitda3471282f14581ed753019e728b37a4c1842425 (patch)
tree9c9c22b9921282d8f57c587bacb0ea6bde918bf5
parent1ea7a17f01ea586c7544fd310376fe14fd79d487 (diff)
downloadaur-da3471282f14581ed753019e728b37a4c1842425.tar.gz
Update to 0.7.1
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD60
2 files changed, 36 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index be8f1cc0964f..c1aff2267faf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = phosh
pkgdesc = A pure Wayland shell prototype for GNOME on mobile devices
- pkgver = 0.7.0
+ pkgver = 0.7.1
pkgrel = 1
url = https://source.puri.sm/Librem5/phosh
arch = i686
@@ -15,7 +15,7 @@ pkgbase = phosh
depends = feedbackd
depends = libhandy
depends = phoc
- source = git+https://source.puri.sm/Librem5/phosh.git#tag=v0.7.0
+ source = git+https://source.puri.sm/Librem5/phosh.git#tag=v0.7.1
source = git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git
source = wlroots.patch::https://source.puri.sm/sebastian.krzyszkowiak/phosh/-/commit/87399f9e40c8475004924732432e677356edfa36.patch
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 43f04c8c3e1f..ef25ab137b14 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,48 +1,56 @@
# Maintainer: Philip Goto <philip.goto@gmail.com>
pkgname=phosh
-pkgver=0.7.0
+pkgver=0.7.1
pkgrel=1
pkgdesc="A pure Wayland shell prototype for GNOME on mobile devices"
url="https://source.puri.sm/Librem5/phosh"
license=("GPL3")
arch=(i686 x86_64 armv7h aarch64)
-depends=('feedbackd'
- 'libhandy'
- 'phoc')
-makedepends=('ctags'
- 'git'
- 'meson'
- 'vala')
+depends=(
+ feedbackd
+ libhandy
+ phoc
+)
+makedepends=(
+ ctags
+ git
+ meson
+ vala
+)
# checkdepends=(xorg-server-xvfb)
-source=("git+${url}.git#tag=v${pkgver}"
- "git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git"
- "wlroots.patch::https://source.puri.sm/sebastian.krzyszkowiak/phosh/-/commit/87399f9e40c8475004924732432e677356edfa36.patch")
-sha256sums=('SKIP'
- 'SKIP'
- 'SKIP')
+source=(
+ "git+${url}.git#tag=v${pkgver}"
+ "git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git"
+ "wlroots.patch::https://source.puri.sm/sebastian.krzyszkowiak/phosh/-/commit/87399f9e40c8475004924732432e677356edfa36.patch"
+)
+sha256sums=(
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+)
prepare() {
- cd phosh
+ cd phosh
- git submodule init
- git config --local submodule.subprojects/gvc.url "$srcdir/libgnome-volume-control"
- git submodule update
-
- patch src/home.c ../wlroots.patch
+ git submodule init
+ git config --local submodule.subprojects/gvc.url "$srcdir/libgnome-volume-control"
+ git submodule update
+
+ patch src/home.c ../wlroots.patch
}
build() {
- arch-meson phosh build
- meson compile -C build
+ arch-meson phosh build
+ meson compile -C build
}
# check() {
-# dbus-run-session xvfb-run \
-# -s '-screen 0 1920x1080x24 -nolisten local' \
-# meson test -C build --print-errorlogs
+# dbus-run-session xvfb-run \
+# -s '-screen 0 1920x1080x24 -nolisten local' \
+# meson test -C build --print-errorlogs
# }
package() {
- DESTDIR="${pkgdir}" meson install -C build
+ DESTDIR="${pkgdir}" meson install -C build
}