summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Booker2022-08-24 18:04:46 +1200
committerThomas Booker2022-08-24 18:04:46 +1200
commitea1260b80588aefbb8cef3fcea738d9113eed884 (patch)
tree9eb535ced18623bec7450532296ec14eb7e53145
parent994e9494e8065c3e0b8427cff4884a8159c581f4 (diff)
downloadaur-ea1260b80588aefbb8cef3fcea738d9113eed884.tar.gz
Updated for 0.20.0 and changed some build configs
Changed the maintainer to Thomas Booker Use git commit hash, not tags Don't need to do anything special for GVC anymore Fix file collide in build by setting libexecdir Changed the build folder to _build
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD28
2 files changed, 18 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ae66f90922bc..9123fbdb4261 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = phosh
pkgdesc = A pure Wayland shell prototype for GNOME on mobile devices
- pkgver = 0.20.beta2
+ pkgver = v0.20.0
pkgrel = 1
url = https://gitlab.gnome.org/World/Phosh/phosh
arch = x86_64
@@ -17,9 +17,7 @@ pkgbase = phosh
depends = libhandy
depends = phoc
depends = polkit
- source = git+https://gitlab.gnome.org/World/Phosh/phosh.git#tag=v0.20.0_beta2
- source = git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git
- b2sums = SKIP
- b2sums = SKIP
+ source = git+https://gitlab.gnome.org/World/Phosh/phosh.git#tag=412c1a2255d31c8f7a648375f727da43c650ec28
+ sha256sums = SKIP
pkgname = phosh
diff --git a/PKGBUILD b/PKGBUILD
index 95bf934f0ced..4acd98d9bc4a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
-# Maintainer: Philip Goto <philip.goto@gmail.com>
+# Maintainer: Thomas Booker <tw.booker@outlook.com>
+# Contributor: Philip Goto <philip.goto@gmail.com>
pkgname=phosh
-pkgver=0.20.beta2
+pkgver=v0.20.0
pkgrel=1
pkgdesc='A pure Wayland shell prototype for GNOME on mobile devices'
arch=(x86_64 aarch64 armv7h)
@@ -21,27 +22,28 @@ makedepends=(
vala
wayland-protocols
)
-_commit=0.20.0_beta2
-source=(
- "git+${url}.git#tag=v${_commit}"
- "git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git"
-)
-b2sums=('SKIP'
- 'SKIP')
+_tag=412c1a2255d31c8f7a648375f727da43c650ec28 # git rev-parse v${pkgver}
+source=("git+${url}.git#tag=${_tag}")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname}
+ git describe --tags
+}
prepare() {
cd phosh
git submodule init
- git config --local submodule.subprojects/gvc.url "$srcdir/libgnome-volume-control"
git submodule update
}
build() {
- arch-meson phosh build # -D gtk_doc=true
- meson compile -C build
+ # If we don't set `libexecdir` then meson will try and place the phosh bin in /lib/phosh and collide with the dir so we put it in /lib/phosh/phosh
+ arch-meson --libexecdir="/usr/lib/${pkgname}" -D tests=false -D systemd=true phosh _build
+ meson compile -C _build
}
package() {
- DESTDIR="${pkgdir}" meson install -C build
+ DESTDIR="${pkgdir}" meson install -C _build
}