summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Booker2022-09-24 08:51:55 +1200
committerThomas Booker2022-09-24 08:51:55 +1200
commitee0e16c8c042bc7112d01e188e0a0704738a21b6 (patch)
treefb379f1494451dac12f61df6594052fb2466e57b
parent7a08ac673c0822ad2b9d0741b36251445b0bd2fc (diff)
downloadaur-ee0e16c8c042bc7112d01e188e0a0704738a21b6.tar.gz
Added pam file to make auth work
-rw-r--r--PKGBUILD13
-rw-r--r--pam_phosh5
2 files changed, 16 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6b4d1bc0b097..daac2e895595 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -32,8 +32,14 @@ makedepends=(
wayland-protocols
)
_tag=4122630266abfd6623e169330da6e7d6bc01be7f # git rev-parse v${pkgver}
-source=("git+${url}.git#tag=${_tag}")
-sha256sums=('SKIP')
+source=(
+ "git+${url}.git#tag=${_tag}"
+ "pam_phosh"
+)
+sha256sums=(
+ 'SKIP'
+ 'b7793f80c533e84ad8adfe8bb46c69f107575e724aa9b53b41f370baa37e4fd5'
+)
pkgver() {
cd phosh
@@ -55,4 +61,7 @@ build() {
package() {
DESTDIR="${pkgdir}" meson install -C _build
+
+ install -Dm644 "$srcdir"/pam_phosh \
+ "$pkgdir"/etc/pam.d/phosh
}
diff --git a/pam_phosh b/pam_phosh
new file mode 100644
index 000000000000..0580d9841cef
--- /dev/null
+++ b/pam_phosh
@@ -0,0 +1,5 @@
+#%PAM-1.0
+
+auth include system-local-login
+account include system-local-login
+session include system-local-login