summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Goto2018-10-24 20:54:15 +0200
committerPhilip Goto2018-10-24 20:54:15 +0200
commit136dccf1a5f58a6e6bc81fab48e499c289b41b58 (patch)
tree2bd2c8282125eda0e02c3f1267981795c34ed0e9
parentad67c705100b62d2b8eef2deb0a9a834bc99d4c9 (diff)
downloadaur-136dccf1a5f58a6e6bc81fab48e499c289b41b58.tar.gz
Update version
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD45
2 files changed, 25 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e864bad89e93..8e0b39a800f1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,12 @@
pkgbase = phosh-git
pkgdesc = A pure Wayland shell prototype for GNOME on mobile devices
- pkgver = latest
+ pkgver = 0.0.1.r44.g3fb62b2
pkgrel = 1
url = https://source.puri.sm/Librem5/phosh
+ arch = i686
arch = x86_64
+ arch = armv6h
+ arch = armv7h
license = GPL3
makedepends = git
makedepends = pkg-config
diff --git a/PKGBUILD b/PKGBUILD
index 4bfda2bce27a..eda0285b3171 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,35 @@
# Maintainer: Philip Goto <philip.goto@gmail.com>
-_pkgname="phosh"
-pkgname="${_pkgname}-git"
-pkgver="latest"
-pkgrel="1"
+pkgname=phosh-git
+pkgver=0.0.1.r44.g3fb62b2
+pkgrel=1
pkgdesc="A pure Wayland shell prototype for GNOME on mobile devices"
-url="https://source.puri.sm/Librem5/${_pkgname}"
+url="https://source.puri.sm/Librem5/phosh"
license=("GPL3")
-
-arch=("x86_64")
-depends=("gtk3"
- "vala"
- "gnome-desktop"
- "gobject-introspection"
- "gtk-doc"
- "libhandy"
- "wlroots")
-makedepends=("git"
- "pkg-config"
- "meson")
-provides=("${_pkgname}")
-conflicts=("${_pkgname}")
-
-source=("git+https://source.puri.sm/Librem5/${_pkgname}.git")
+arch=(i686 x86_64 armv6h armv7h)
+depends=(gtk3
+ vala
+ gnome-desktop
+ gobject-introspection
+ gtk-doc
+ libhandy
+ wlroots)
+makedepends=(git
+ pkg-config
+ meson)
+provides=(phosh)
+conflicts=(phosh)
+source=("git+https://source.puri.sm/Librem5/phosh.git")
sha256sums=("SKIP")
pkgver() {
- cd "${_pkgname}"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd phosh
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
rm -rf build
- arch-meson "${_pkgname}" build -Dtests=false
+ arch-meson phosh build -Dtests=false
ninja -C build
}