summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Goto2018-12-22 17:22:22 +0100
committerPhilip Goto2018-12-22 17:22:22 +0100
commit2463dd4672a11b3a86b1a55a4d41b9aa7ad870d3 (patch)
tree08ef30c955ec4dc63edcb986e3999fc4ec52ea1e
parent136dccf1a5f58a6e6bc81fab48e499c289b41b58 (diff)
downloadaur-2463dd4672a11b3a86b1a55a4d41b9aa7ad870d3.tar.gz
Add check
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8e0b39a800f1..0864042b1286 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = phosh-git
pkgdesc = A pure Wayland shell prototype for GNOME on mobile devices
- pkgver = 0.0.1.r44.g3fb62b2
+ pkgver = 0.0.2.r21.gade8659
pkgrel = 1
url = https://source.puri.sm/Librem5/phosh
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index eda0285b3171..4e3dcffbe183 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Philip Goto <philip.goto@gmail.com>
pkgname=phosh-git
-pkgver=0.0.1.r44.g3fb62b2
+pkgver=0.0.2.r21.gade8659
pkgrel=1
pkgdesc="A pure Wayland shell prototype for GNOME on mobile devices"
url="https://source.puri.sm/Librem5/phosh"
@@ -29,10 +29,14 @@ pkgver() {
build() {
rm -rf build
- arch-meson phosh build -Dtests=false
+ arch-meson phosh build
ninja -C build
}
+check() {
+ ninja -C build test
+}
+
package() {
DESTDIR="${pkgdir}" ninja -C build install
}