summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Goto2019-11-08 14:12:09 +0100
committerPhilip Goto2019-11-08 14:12:09 +0100
commit5044c605bb5881209664111cad2d3719ad08c381 (patch)
tree9c822a57ecedc9bead509d30d72ed023a07e4000
parentc9d1d3385aa9a0ac95aed7538e935e6ce39be0ac (diff)
downloadaur-5044c605bb5881209664111cad2d3719ad08c381.tar.gz
Update package to latest version
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD19
2 files changed, 20 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ea3d786e4714..bbc22206b368 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = phosh-git
pkgdesc = A pure Wayland shell prototype for GNOME on mobile devices
- pkgver = 0.0.2.r54.gcdcb873
+ pkgver = 0.1.2.r8.gd001a3d
pkgrel = 1
url = https://source.puri.sm/Librem5/phosh
arch = i686
@@ -16,12 +16,15 @@ pkgbase = phosh-git
depends = gcr
depends = gnome-desktop
depends = libhandy
- depends = libpulse
+ depends = libnm
+ depends = libsecret
depends = upower
depends = wlroots
provides = phosh
conflicts = phosh
source = git+https://source.puri.sm/Librem5/phosh.git
+ source = git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git
+ sha256sums = SKIP
sha256sums = SKIP
pkgname = phosh-git
diff --git a/PKGBUILD b/PKGBUILD
index c42545b7d6e4..945b3bd1d77c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Philip Goto <philip.goto@gmail.com>
pkgname=phosh-git
-pkgver=0.0.2.r54.gcdcb873
+pkgver=0.1.2.r8.gd001a3d
pkgrel=1
pkgdesc="A pure Wayland shell prototype for GNOME on mobile devices"
url="https://source.puri.sm/Librem5/phosh"
@@ -10,7 +10,8 @@ arch=(i686 x86_64 armv6h armv7h)
depends=(gcr
gnome-desktop
libhandy
- libpulse
+ libnm
+ libsecret
upower
wlroots)
makedepends=(ctags
@@ -20,14 +21,24 @@ makedepends=(ctags
vala)
provides=(phosh)
conflicts=(phosh)
-source=("git+https://source.puri.sm/Librem5/phosh.git")
-sha256sums=("SKIP")
+source=("git+https://source.puri.sm/Librem5/phosh.git"
+ "git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git")
+sha256sums=("SKIP"
+ "SKIP")
pkgver() {
cd phosh
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ cd phosh
+
+ git submodule init
+ git config --local submodule.subprojects/gvc.url "$srcdir/libgnome-volume-control"
+ git submodule update
+}
+
build() {
arch-meson phosh build
ninja -C build