summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Goto2021-07-28 13:47:05 +0200
committerPhilip Goto2021-07-28 13:47:05 +0200
commitad1684ff55e857c04d47bba249cde0fd01385630 (patch)
tree76a550445126d40279f59932f4de233a20ad790f
parentf0534cbab36dead4c363e9e5380e104ad0c026ad (diff)
downloadaur-ad1684ff55e857c04d47bba249cde0fd01385630.tar.gz
Sync to non-git version
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD29
2 files changed, 16 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 261c5e958e1c..7c7b9a78a85c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,9 @@
pkgbase = phosh-git
pkgdesc = A pure Wayland shell prototype for GNOME on mobile devices
- pkgver = 0.7.1.r13.g0ca4ab1
+ pkgver = 0.12.1.r2.g3e1ba9d
pkgrel = 1
url = https://source.puri.sm/Librem5/phosh
- arch = i686
arch = x86_64
- arch = armv7h
arch = aarch64
license = GPL3
makedepends = ctags
@@ -23,4 +21,3 @@ pkgbase = phosh-git
sha256sums = SKIP
pkgname = phosh-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 705e5a4d6af9..bb16164bdba2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,28 @@
# Maintainer: Philip Goto <philip.goto@gmail.com>
pkgname=phosh-git
-pkgver=0.7.1.r13.g0ca4ab1
+pkgver=0.12.1.r2.g3e1ba9d
pkgrel=1
-pkgdesc="A pure Wayland shell prototype for GNOME on mobile devices"
-url="https://source.puri.sm/Librem5/phosh"
-license=("GPL3")
-arch=(i686 x86_64 armv7h aarch64)
+pkgdesc='A pure Wayland shell prototype for GNOME on mobile devices'
+url='https://source.puri.sm/Librem5/phosh'
+license=('GPL3')
+arch=(x86_64 aarch64)
depends=(
- 'feedbackd'
- 'libhandy'
- 'phoc'
+ feedbackd
+ libhandy
+ phoc
)
makedepends=(
- 'ctags'
- 'git'
- 'meson'
- 'vala'
+ ctags
+ git
+ meson
+ vala
)
provides=(phosh)
conflicts=(phosh)
+# checkdepends=(xorg-server-xvfb)
source=(
- "git+https://source.puri.sm/Librem5/phosh.git"
+ "git+${url}.git"
"git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git"
)
sha256sums=('SKIP' 'SKIP')
@@ -40,7 +41,7 @@ prepare() {
}
build() {
- arch-meson phosh build
+ arch-meson phosh build # -D gtk_doc=true
meson compile -C build
}