summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Goto2018-08-15 22:46:51 +0200
committerPhilip Goto2018-08-15 22:46:51 +0200
commitad67c705100b62d2b8eef2deb0a9a834bc99d4c9 (patch)
treefec8c4616ba950d85c46762e66353cc17b980295
downloadaur-ad67c705100b62d2b8eef2deb0a9a834bc99d4c9.tar.gz
Initialize package
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD41
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e864bad89e93
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = phosh-git
+ pkgdesc = A pure Wayland shell prototype for GNOME on mobile devices
+ pkgver = latest
+ pkgrel = 1
+ url = https://source.puri.sm/Librem5/phosh
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = pkg-config
+ makedepends = meson
+ depends = gtk3
+ depends = vala
+ depends = gnome-desktop
+ depends = gobject-introspection
+ depends = gtk-doc
+ depends = libhandy
+ depends = wlroots
+ provides = phosh
+ conflicts = phosh
+ source = git+https://source.puri.sm/Librem5/phosh.git
+ sha256sums = SKIP
+
+pkgname = phosh-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4bfda2bce27a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Philip Goto <philip.goto@gmail.com>
+
+_pkgname="phosh"
+pkgname="${_pkgname}-git"
+pkgver="latest"
+pkgrel="1"
+pkgdesc="A pure Wayland shell prototype for GNOME on mobile devices"
+url="https://source.puri.sm/Librem5/${_pkgname}"
+license=("GPL3")
+
+arch=("x86_64")
+depends=("gtk3"
+ "vala"
+ "gnome-desktop"
+ "gobject-introspection"
+ "gtk-doc"
+ "libhandy"
+ "wlroots")
+makedepends=("git"
+ "pkg-config"
+ "meson")
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+
+source=("git+https://source.puri.sm/Librem5/${_pkgname}.git")
+sha256sums=("SKIP")
+
+pkgver() {
+ cd "${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ rm -rf build
+ arch-meson "${_pkgname}" build -Dtests=false
+ ninja -C build
+}
+
+package() {
+ DESTDIR="${pkgdir}" ninja -C build install
+}