summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Booker2023-02-26 18:37:46 +1300
committerThomas Booker2023-02-26 18:37:46 +1300
commitb6939c4e8c21a23ecc385934f8b13fa88b8689ba (patch)
tree0d618e75b2cc7c8a51b50a6d347e7972a2d223f6
parente15e82403981813c1a2c8e0c2d88cc1cadb3d2e0 (diff)
downloadaur-b6939c4e8c21a23ecc385934f8b13fa88b8689ba.tar.gz
Update for 0.24.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD17
2 files changed, 17 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 191629189988..476a8debfab0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = phosh-git
pkgdesc = A pure Wayland shell prototype for GNOME on mobile devices
- pkgver = 0.21.0.r40.g2c03f935
+ pkgver = 0.24.0.r54.g87a16b18
pkgrel = 1
url = https://gitlab.gnome.org/World/Phosh/phosh
arch = x86_64
@@ -20,13 +20,17 @@ pkgbase = phosh-git
depends = feedbackd
depends = libnm
depends = evolution-data-server
- depends = phoc-embedded-wlroots>=0.21.0
+ depends = phoc-embedded-wlroots
depends = gnome-shell
depends = callaudiod
depends = polkit
+ depends = libadwaita
+ depends = evince
provides = phosh
conflicts = phosh
source = git+https://gitlab.gnome.org/World/Phosh/phosh.git
+ source = pam_phosh
sha256sums = SKIP
+ sha256sums = b7793f80c533e84ad8adfe8bb46c69f107575e724aa9b53b41f370baa37e4fd5
pkgname = phosh-git
diff --git a/PKGBUILD b/PKGBUILD
index b8a6bb113b9f..8f1cefc400d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Philip Goto <philip.goto@gmail.com>
pkgname=phosh-git
-pkgver=0.21.0.r40.g2c03f935
+pkgver=0.24.0.r54.g87a16b18
pkgrel=1
pkgdesc='A pure Wayland shell prototype for GNOME on mobile devices'
arch=(x86_64 aarch64 armv7h)
@@ -21,10 +21,12 @@ depends=(
evolution-data-server
# Replace this with phoc once it works.
#'phoc>=0.21.0'
- 'phoc-embedded-wlroots>=0.21.0'
+ phoc-embedded-wlroots
gnome-shell
callaudiod
polkit
+ libadwaita
+ evince
)
makedepends=(
meson
@@ -40,7 +42,7 @@ source=(
sha256sums=(
'SKIP'
'b7793f80c533e84ad8adfe8bb46c69f107575e724aa9b53b41f370baa37e4fd5'
- )
+)
pkgver() {
cd phosh
@@ -50,16 +52,19 @@ pkgver() {
prepare() {
cd phosh
- git submodule init
- git submodule update
+ git submodule update --init
}
build() {
# If we don't set `libexecdir` then meson will try and place the phosh bin in /lib/phosh and collide with the dir so we put it in /lib/phosh/phosh
- arch-meson --libexecdir="/usr/lib/phosh" -D tests=false -D systemd=true phosh _build
+ arch-meson --libexecdir="/usr/lib/phosh" -D tests=true -D phoc_tests=disabled -D man=true -D gtk_doc=false -D callui-i18n=true -D lockscreen-plugins=true -D systemd=true phosh _build
meson compile -C _build
}
+check() {
+ xvfb-run meson test --no-suite screenshots -C _build
+}
+
package() {
DESTDIR="${pkgdir}" meson install -C _build